Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Nvidia Shield + Litchi 2.3.1 problems

Discussion in 'Pro/Adv Discussion' started by Cynical, Feb 9, 2016.

  1. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Hi guys!
    I just finally solved so that i have a Phantom 3 Pro on FW 1.4.
    I also managed to get help from Litchi so that i have version 2.3.1

    My problem is that on my Nvidia shield tablet, i can open the Litchi without problem.
    But if i startup my controller, then litchi it crashed staight away.

    Anyone have similar issues and found a solution? I cant get Llitchi to work without instant crash when started my Phantom controller.
     
  2. ScatSpeak

    Joined:
    Oct 19, 2015
    Messages:
    203
    Likes Received:
    75
    Location:
    MO, USA
    Which Nvidia Shield? What is the Android OS version? What is Litchi configuration for video decoding set to and have you tried them all with same result? What happens if you start the RC first before connecting USB to tablet? etc., etc., etc....
     
  3. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    I suspect you're on Android 6.0. In which case you'll need to check android 6.0 encoding and all will be well. Having said that your Shields compass won't work on 6.0. That may or may not be an issue for you depending on how you fly.
     
    pomonabill220 and Cynical like this.
  4. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Yeah im on 6.0.
    How do i solve encodings?
    Why wont compass work? Can I somehow solve that too?


    Sent from my iPhone using PhantomPilots mobile app
     
  5. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    If you go in to 'camera' on the app, then click on video decoding you'll see an option for hw android 6.0, use that and it won't crash anymore. The compass issue on 6.0 is not fixable until they release a patch for it I'm afraid. I downgraded back down to lollipop because of this.
     
    pomonabill220 likes this.
  6. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    I can live with downgraded android.
    What version should i look for =P

    Hugh thanx for the help. Gonna try this now.
     
  7. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
  8. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Hmm one question.
    Did you mean that i should open the normal camera app and change settings?
    Cant find any settings at all lol.

    And in Litchi under Camera. If i change decoding i can only pick Hardware or Software.
     
  9. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    What version of Litchi are you on. Mines 2.71 which has 3 options....Hardware, software and hardware 6.0.
     
  10. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    I have 2.3.1 (for no height limit) dont need it in sweden and in the area where i live.
    Accually.. i bought this without knowing they implented the limits :(
    Just trying to fix it now so i can use it the way i intended lol
     
  11. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    There's always a way!
     
    Cynical likes this.
  12. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Hmm right now im stucked.
    I only have hardware and software as options. And both keps crashing :(
     
  13. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    Well, I can only suggest that you upgrade Litchi, 500 metres isn't exactly low is it?
     
  14. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    Or ideally, if you must fly higher, downgrade to lollipop.
     
    ScatSpeak likes this.
  15. ScatSpeak

    Joined:
    Oct 19, 2015
    Messages:
    203
    Likes Received:
    75
    Location:
    MO, USA
    Yep, that's exactly right... the version of Litchi that you (OP) insist on using to bypass the DJI altitude restrictions didn't have support for Android 6.0 video encoding yet...
     
  16. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Ok. So downgrade to lollipop is my last shot to get this to work.
    Hope its not to complicated
     
  17. Frankc

    Joined:
    Jan 6, 2016
    Messages:
    655
    Likes Received:
    137
    Location:
    Malvern, Worcestershire, England
    sorry to add to the confusion. I have a new NVIDIA shield K1 and running the usual DJI app. Updated firmware etc.

    I was hoping to get the Litchi app to run on my Phantom 3. Is there a problem with this? Are there versions I should avoid?

    Thanks
     
  18. Wacker2611

    Joined:
    Sep 10, 2015
    Messages:
    444
    Likes Received:
    164
    Not really. What version of android are you using?
     
  19. neven

    Joined:
    Jan 5, 2016
    Messages:
    342
    Likes Received:
    115
    Location:
    Zagreb, Croatia, Europe
    As Wacker said stay on Lollipop and use latest Litchi.
     
  20. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Oh ****... thought id made it.
    Downgraded to Lollipop. Theres a good video on the tube on how to do it.

    Installed Litchi 2.3.1 and ran it. I can get it to run now. But cant connect the aircraft.
    Disconnected is all i get. Press it.. it searches. But cant connect =/

    Any clues?
     
    rene van der meer and Badfinger like this.