Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Nvidia Shield Go App not connecting/detecting

Discussion in 'Phantom 3 Help' started by upgraders, Dec 9, 2015.

  1. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    Hi all, I just upgraded my P2 and bought a P3 and love it. I have taken it out using my iPhone 6 and everything works.

    Current Firmware: Aircraft - 1.5.30 and RC - 1.5.70

    I decided I wanted a larger screen and there has been a ton of great feedback on the android Nvidea Shield so that is what I chose to go with. I installed the only version available from Google play version
    2.4.2 the Nvidea is running 5.1.1 Lollipop. Its a new tablet so it was after the recall period and I have enabled developer mode AND turned on USB debugging. I can't however get the app to detect the P3 it is foever on the "Connect your device" I have rebooted the tablet, the transmitter and the drone and I have tried several USB plugs (yes it is plugged into the back of the transmitter. The USB works just fine connecting the shield to a PC.

    So I am hoping someone can chime in with a silver bullet to fix this. The is the first and only Android device I have ever owned an I got it specifically for my P3.

    Thanks!!
    Jason
     
  2. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    Plug your USB cable into the tablet after your RC and phantom are turned on.
     
  3. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    I tried that and every other sequence, but I just tried again in exactly that order and it still does not detect it :(
     
  4. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    On the connect your device screen, does the GO app display the Phantom? Also, did the Shield ask about "default app when this usb device is connected"
     
  5. Milfodd

    Joined:
    Dec 1, 2015
    Messages:
    6
    Likes Received:
    6
    I too have the shield. My start up routine is as follows:
    1] Tablet is powered up, attached to the controls and the USB cable is plugged in.
    2] Power up the controls - DJI Go set to autolaunch (or just launch the app)
    3] Power up the P3.
    4] The app then connects and away I go!

    I'm sure you may have attempted this combination but I just wanted to share what works for me.
    Good luck!
     
  6. Milfodd

    Joined:
    Dec 1, 2015
    Messages:
    6
    Likes Received:
    6
    I should add that I have the Shield K1
     
  7. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    It does not ask me anything. It shows the connection options and defaults on the Inspire, but I have moved it to the P3 Pro and it still does not do anything. I've uninstalled and reinstalled the app twice. (I can connect to a computer and view the files on the shield so I know the darn USB works on it :/
     
  8. Dirby

    Joined:
    Mar 14, 2014
    Messages:
    823
    Likes Received:
    128
    Location:
    Dothan Al
    you said that you had turned the usb debugging ON.
    i thought it was supposed to be turned off?
    thc D
     
  9. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    I read on a couple of other forums, after not being able to connect right out of the box that the USB debugging had to be on.. so I have tried it with and without it on. Still no dice.
     
  10. mick74

    Joined:
    Jul 14, 2015
    Messages:
    82
    Likes Received:
    9
    you said it defaults on the Inspire, then you moved it to the P3 Pro, At this point you need to tap the (Enter Camera View) bar. If it come up Disconnected, Restart your RC.
     
  11. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)

    I guess you missed the other part of that comment " It shows the connection options and defaults on the Inspire, but I have moved it to the P3 Pro and it still does not do anything. " I do that and the camera bar never comes up. It's as if the USB cable is not connected to the device, however as I said, it is connected and I have tried and tested other cables that connect to the PC just fine from the nVidea. This is driving me nuts. surely there is a setting somewhere that needs to be "switched on or off" on the tablet. Everything works as it is supposed to, just not together.

    Thanks for everyone's continued input.
     
  12. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    I understand your frustration, we are trying to help.

    A couple more thing to try -
    On the Shield - not connected to RC - go to Settings, Apps, downloaded, DJI Go. Look for Launch by default, then clear defaults. Then power on the RC, with the Shield on - usb not connected, Go app not running. Plug usb in then start go app. You should be asked if you want this app to be the default when this device is plugged in. Your choice, yes or just once. if you chose just once, it will ask you every time.

    Also, after you start the Go app, try signing in to your Skypixel account. From the start screen - you cant get passed - click the Me button, lower right.
     
    bbfpv likes this.
  13. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    Thanks for the help, it is appreciated... DJI's answer was you should have bought an approved device. I won't be able to test your suggestions til later at home, but I will do that and let you know.
     
  14. Jethro-421

    Joined:
    May 24, 2015
    Messages:
    22
    Likes Received:
    12
    upgraders-

    I had this same issue (though with a Nexus 7 tablet.) One question.....are you able to, or have you tried, to update the RC firmware using the usb port on the RC? In my case I was not, so we (me and DJI) determined that there was a fault in the operation of the USB logic (I say logic, because I tried swapping the module on the RC with a known working module, and still no go) so I sent me RC in for diagnostics and repair. FedEx claims that I'll be receiving my "repaired" RC (don't know if they actually repaired it, or are just sending me a new one) this afternoon.

    Anyway, just thought I'd throw out there my experience since I was in the same boat as you.....hope it helps!

    R
     
  15. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    The quad is only about 2 weeks old. I updated the Firmware the next day I got it using the GO app and my iPhone and it worked fine.... so I guess technically yes I updated it through the USB port (just with the Lighting connector to USB from my iphone 6) Not that I think it should matter, but I did upgrade the USB module on that back with the HDMI capable one
     
  16. upgraders

    Joined:
    Feb 1, 2014
    Messages:
    25
    Likes Received:
    3
    Location:
    Dayton Ohio Area (Beavercreek)
    I just got home and tried what you said and on clearing the cache and resetting the defaults and nothing. So just for S***S and giggles I found a few other USB cables (Now I had tried 2 other ones, but I got one that came from another device actually a short 12" white one from something I bought. Plugged it in and it recognized the RC and the camera button came up! everything works as it should.

    So my take away here is that NOT ALL USB CABLES ARE THE SAME. I am not sure what is so magical about this other one, but it works!

    Thanks everyone for their help.. time to go enjoy this thing!

    Jason
     
    bobmyers and mick74 like this.
  17. TrynFlyn

    Joined:
    Nov 4, 2015
    Messages:
    139
    Likes Received:
    42
    Great news Jason. Sometimes it is the simple things.

    Happy flying.
     
  18. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,751
    Likes Received:
    1,093
    Location:
    Long Island, NY
    awesome. have fun!