Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional No Live Video Feed on P3P using DJI Go or Litchi

Discussion in 'Phantom 3 Help' started by Rob Robertson, May 29, 2016.

  1. Rob Robertson

    Joined:
    Jun 24, 2015
    Messages:
    75
    Likes Received:
    44
    I have been having problems with my Phantom 3 Pro.



    I have eliminated some possible causes, but I’m having no luck solving the problem. Everything seems to be working fine except for the live video transmission.



    I get full strength on the RC connection, Full strength on the video transmission, Plenty of satellites, (Not that it would make any difference) , I was receiving telemetry as I flew the drone, The camera was working and recording just fine to the SD card, and I was able to move the gimbal up and down using the RC. So there was full communication between the RC and the aircraft, yet, I still get the red “No Signal” bar at the top of DJI Go, and have no view from the camera.



    Here are some specifics:



    I have had no trouble like this before. Every flight I have taken up until now has been fine with no video trouble aside from some temporary dropouts in areas with interference.



    I used the drone a few days earlier and had a perfect flight. Nothing unusual; happened during the flight. No hard landings, crashes, or anything else. The video feed was working fine right until I shut it down and put it back in its case.



    Yesterday, when I took it out and powered it up, it was like this, with no video feed. I was running an old firmware, Version 1. 4.0010. I was using an old DJI Pilot app as well, and an older version of Litchi. I stopped updating before the firmware version that limited my altitude to 500M.



    I ran both DJI and the Litchi app each separately and had the same issue with both apps.

    So this tells me that neither app is to blame for the issue.



    After checking everything I could think of, and not having anyone from DJI that I could get ahold of at the time, I thought perhaps updating the firmware might solve the issue.



    I downloaded the latest DJI Go app (Downloaded from Google Play on 5/29/16) and let the app update my controller to the latest firmware, which appears to be version 1.6 for the controller. I went to the DJI Website and grabbed the latest firmware for the aircraft which was version 1.8.80. After a couple tries everything updated correctly and the DJI Go app now tells me that I have the most current Firmware for the controller, the aircraft, the camera, and all my batteries.



    I also updated the Litchi app to the latest version, also downloaded on 5/29/16.



    I tried it again, and this did not solve my problem.



    Then, I did all the calibrations I could think of IMU, and compass, and even the gimbal, and then re-linked the aircraft to the RC, even though they were already connecting, just out of desperation.



    No effect. Still no video feed.



    Just to be sure it wasn’t my tablet (Which by the way, is a Google Nexus 7” 2013 version) I hooked up a Samsung Galaxy 5 smartphone, downloaded the Go app onto that, logged into my DJI account, plugged it into my controller, and ran it using that phone, and the result was the same. Still no video feed.



    I grabbed a different cable and swapped that out (One of the white DJI cables that came with it) and that made no difference.



    So I know that the problem was NOT:



    1. A corrupt app

    2. A Bad Cable

    3. My Tablet

    4. A weak connection from the RC to the Aircraft

    5. A weak video transmission signal, (since it had all the strength bars)

    6. An un-linked Aircraft

    7. Firmware problems (Since the problem was the same with two different Firmware versions, several generations apart

    8. lack of calibrations

    9. The camera itself, (because it recorded fine to the SD card, and I had control of turning it on and off and moving the gimbal from the RC)

    10. Caused by damage from a crash, mishandling, or a hard landing







    In the (poor and rather shaky) video I am linking to this post, you can see all the signal strengths in the interface for both Litchi and DJI Go. You can see that telemetry is coming back to the tablet while I fly the aircraft, you can see that the RC is connected to the aircraft, you can see the video settings I am using, (I usually use 4K and started with that, but tried lowering it to 1080p just to see if there was a difference – There wasn’t) you can see that I tried manually selecting a video transmission channel instead of using Auto, and it didn’t fix the problem. I tried it with Hardware acceleration both on and off and neither fixed the problem.

    Here is the video link:


    So the only question left is what IS causing the problem and how do I fix it?





    Anyone care to take a stab at this?



    I looked through the forums and this problem came up a lot back in the earlier firmware versions, but very few of the posts that complained about the problem were solved, and those that were, got solved by doing some of the things I have already tried. I didn’t see any other complaints of this type while using the new firmware, but since it was happening with both the older version and this version, again, I don’t believe it’s a firmware problem.



    Thank you, and I hope someone out there can help me.



    Bob
     
  2. David Dismukes

    Joined:
    Oct 26, 2015
    Messages:
    1
    Likes Received:
    0
    My P3 advanced did the same thing. Updated the new software on the receiver and have had no problems.
     
  3. Rob Robertson

    Joined:
    Jun 24, 2015
    Messages:
    75
    Likes Received:
    44
    Unfortunately, I did update the firmware on the controller, on the aircraft, and updated both apps as well as trying a different tablet, none of which solved my problem.

    I am glad that worked for you, but something else is going on here. Same issue with Firmware 1.4 and 1.8
     
    #3 Rob Robertson, May 29, 2016
    Last edited: May 30, 2016
  4. kevin cahill

    Joined:
    May 14, 2016
    Messages:
    18
    Likes Received:
    0
    I have all the same problems as you, did all of the same changes , but nothing worked , did you ever get a fix for this issue.
     
  5. Rob Robertson

    Joined:
    Jun 24, 2015
    Messages:
    75
    Likes Received:
    44
    Kind of.... I bought another P3P.

    I needed to solve the issue within a few days, and didn't have time to send the old one back to DJI. It looks like that will be what I have to do. I have gotten nowhere with a solution.
     
  6. kevin cahill

    Joined:
    May 14, 2016
    Messages:
    18
    Likes Received:
    0
    I am thinking about doing the same, this is a exercise in fustration.

    Sent from my LG-D852 using PhantomPilots mobile app
     
  7. EPT160

    Joined:
    Sep 30, 2015
    Messages:
    92
    Likes Received:
    15
    Location:
    Australia
    I also had exactly the same issues as Rob R describes in original post. No 720p video downlink.

    I ended up buying a new camera and gimbal from ebay and this fixed the issue. It is cheaper then a new bird, plus you end up with a few spares.

    Very easy to fit.
     
  8. Richard R

    Joined:
    Jan 27, 2016
    Messages:
    672
    Likes Received:
    245
    Location:
    Ohio
    Just a thought, you have both the Go and Litchi apps. Are you sure that one is definitely turned off when you are using the other and not just 'asleep'? Running one app with the other on in the background has been known to cause problems.
     
  9. kevin cahill

    Joined:
    May 14, 2016
    Messages:
    18
    Likes Received:
    0
    Had all these same issues with my P3A, found the problem finally, check under the VPS module, that is where the wifi receiver module sits, on the receiver module there is a 6 pin connector and one of my pins came loose from the board, i have ordered an new wifi receiver module part# 35 from.

    Sent from my LG-D852 using PhantomPilots mobile app
     
  10. kevin cahill

    Joined:
    May 14, 2016
    Messages:
    18
    Likes Received:
    0