Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No gimbal after upgrade

Discussion in 'Phantom 2 Vision + Help' started by Manxx, May 21, 2015.

  1. Manxx

    Joined:
    May 21, 2015
    Messages:
    3
    Likes Received:
    0
    Few days ago I got my 10 months old PV2+ v2.0 out from the closet for the summer season. Charged the battery and connected to PC. The Assistant software (3.8) showed available upgrades. There was the v3.12 upgrade. When upgrading, the ZEN IMU was also upgraded, then the gimbal/camera starting making erratic moves, software asked to repower the unit. Since then, the gimbal went dead.

    Now the firmware upgrade window does not have the ZEN IMU line. I tried reapplying upgrades, recalibrating IMU and the RC - NONE will reinstall the ZEN IMU firmware. Assistant software thinks I have PV2 (not PV2+).

    I've searched the net and found others with the same issue, but no solution.

    I contacted DJI, they claim that this is the first time they are hearing about this, even though their own support forum is plastered with posts about this issue. **** upgrade, the phantom was in perfect condition before it, now the gimbal is gone.

    Has anybody seen a fix for this?
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,416
    Likes Received:
    568
    Location:
    Sydney Australia
    Can you open up the phantom?
    If so you will need to do a full naza reset.


    This is step by step
     
  3. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    I had the exact same issue. After the upgrade my Zen IMU firmware was removed. Everything was working fine before the upgrade. Had to RMA my unit. They had to replace the camera. Somehow the upgrade blew the gimbal function. The camera still worked but they replaced it all. I would contact support and ask for J.S. He is aware of this issue.
    I did this after trying everything possible. Full hard reset. Reverting back to 3.08, re calibrations , nothing would bring back the Zen IMU.
    Good luck!
     
  4. Manxx

    Joined:
    May 21, 2015
    Messages:
    3
    Likes Received:
    0
    Roy, have you tired the above procedure posted by Marko?
     
  5. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    Yes I did the hard reset and reloaded the software butt no ZenIMU which means it can't see the hardware since the upgraded killed the gimbal control. DJI had to replace the camera to get it to work since again.
    Camera and gimbal were working fine till upgrade then hardware was no longer seen. I suspect the gimbal controller broad was bricked and d a aged during the upgrade somehow. ???????
     
  6. Manxx

    Joined:
    May 21, 2015
    Messages:
    3
    Likes Received:
    0
    You right, hard reset did not work for me either (just tried it, thanks Marko for the videos)).
    Got RMA from DJI, will send it tomorrow, I really hope it will be covered by the warranty. Too bad it will take +6 weeks.