Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No battery / Satellite % and no camera movement.

Discussion in 'Phantom 2 Vision + Discussion' started by laynesway, May 2, 2014.

  1. laynesway

    Joined:
    Apr 15, 2014
    Messages:
    27
    Likes Received:
    0
    My phantom vision app connects fine and gives me video (also the gimbal portion of the camera works) However the controls for the camera wont move it, nor will it show the battery percentage or number of satellites connected. It does show the SD card status though. Ive searched and tried everything to get this to work, but with no luck! Ive opened the case to make sure all the connectors were connected, checked to make sure no wires we damaged, rebinded a dozen times, performed all updates, made sure camera was on wifi, checked all app settings. Just updated today. Still nothing???
     
  2. laynesway

    Joined:
    Apr 15, 2014
    Messages:
    27
    Likes Received:
    0
    Also I'm using Samsung galaxy s4.
     
  3. DrJoe

    Joined:
    Apr 13, 2014
    Messages:
    591
    Likes Received:
    96
    By any chance are you using app version XXX.40? Search dirtybird. he posted about this issue, I believe. Installing the XX.39 version fixed it. I'm an Apple guy, so I can't help you further, sorry.
     
  4. RedRyderMedia

    Joined:
    Apr 7, 2014
    Messages:
    750
    Likes Received:
    31
    One other thing to check, you can toggle the flight information on and off. Do you have it toggled off by chance? Look for an icon in the lower right of the screen. Touch the icon and see if everything appears.