Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Lost FPV, did not come back

Discussion in 'Pro/Adv Discussion' started by max, May 26, 2015.

  1. max

    max

    Joined:
    Sep 19, 2014
    Messages:
    199
    Likes Received:
    6
    I've only had about 4 flights so far with my P3. Last flight I lost video signal, so I hit RTH. Bird came back and I regained control, but the video signal never came back. It was black and said no signal. Power cycled the bird 2x and it still was black. Shut down the app and restarted it and the video feed came back. But I didn't like losing my FPV in flight like that... Anyone else have this problem. On Android (Dell venue tablet)
     
  2. Alothan

    Joined:
    May 4, 2015
    Messages:
    36
    Likes Received:
    23
    Location:
    Canada
    I have. It's usually caused by a loose cable connection to my phone. Shut down and reconnected cable fixed it for me every time.
     
  3. DrewFlies

    DrewFlies Guest

    Well, you have a Dell. That explains a lot. Dell is crap. On another note, yes this happened to me. Hit RTH once it was above me and 100ft up in there air while descending, I backed out of app to the main menu of the app then pressed the camera icon to go fpv and signal came back.. But, at no point did it regain signal on its own and it clearly had some type of signal because it asked me if I wanted to RTH or cancel on the app and I also was able to hit RTH on the remote control
     
  4. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,745
    Likes Received:
    1,092
    Location:
    Long Island, NY
    FPV and control are independent of one another. You can still control the quad w/o FPV.
     
  5. DrewFlies

    DrewFlies Guest

    You are right. Why would it ask me to RTH on the app if there was no signal for fpv.
    I didnt even attempt to try it through the app to see if it would work. I just used the r/c
     
  6. AHill

    Joined:
    Oct 10, 2013
    Messages:
    227
    Likes Received:
    23
    It could be the speed of the tablet you are using. I tried several tablets, worked good on the Nexus 7 and Moto, video was breaking up on an older Galaxy Note 2. App was still connected but tablet could not keep up with speed of Lightbridge video at 720 P. Video was breaking up and sometimes losing it. Tried this in same room while testing but at a distance the signal would be weaker and would likely have more of a problem keeping up.
     
  7. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,221
    Likes Received:
    914
    Location:
    Indy, USA
    Anytime you detect a problem 1st and most important is to bring it home and get it landed. No point in trying to force into a fly-away.

    *At a minimum get it landed and reboot everything and start out fresh again.
     
  8. Endoric

    Joined:
    Jun 6, 2015
    Messages:
    5
    Likes Received:
    0
    I lost my video feed today but i believe it was my samsung phone connecting to my wifi...
    I believe the weak link in the entire system is the app. When i loose my video feed i need to restart the phone as once the app fails it never starts up again correctly.
     
  9. vagoat

    Joined:
    May 30, 2015
    Messages:
    28
    Likes Received:
    7
    Location:
    Virginia
    I've lost video feed but that is because the signal is through trees. How much farther can you go before you lose the remote/control? I guess I could fly by map a bit farther.
     
  10. fhk

    fhk

    Joined:
    May 10, 2015
    Messages:
    70
    Likes Received:
    18
    It does seem that once the video feed is lost it is gone for good but you do still have control. I havent tried unplugging and re-plugging the usb but that might bring it back. Keep an eye on your status bar and when it tells you video signal weak start returning or increase altitude.