Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Litchi have removed Phantom Vision support in the Beta Version of the App

Discussion in 'Phantom 2 Vision + Discussion' started by CEEJAY, Jan 31, 2016.

  1. CEEJAY

    Joined:
    May 3, 2015
    Messages:
    55
    Likes Received:
    6
    Location:
    Norfolk, England
    Be wary all Vision 2 plus owners !!!
    Do not to upgrade to the latest (Beta) version of Litchi !!,
    it does not support the Vision Range anymore ! (see release text below)
    Great!, so , do we now get a Full refund because it does not support our Machines anymore Mr Litchi ???



    Hello,

    A new version of Litchi (3.0.1) is available for beta testing.
    This version has been updated to the DJI development kit 3.0 which means Litchi now supports 3 new platforms: the P3 Standard, P3 4K and Inspire 1 Pro.
    Support for the Phantom 2 Vision series has been removed. If you are a Phantom 2 user, do not update to this version.
    You can opt in or opt out of beta testing here

    3.0.1 changelog:

    • added support for P3 Standard, P3 4K and Inspire 1 Pro
    • removed P2 vision and P2 vision + support
    • aircraft model is now automatically detected
    • added new camera shooting modes (HDR and AEB)
    • gimbal movements improvements for Focus POI setting (waypoint mode)
    removed aircraft type and video decoder settings
     
  2. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,374
    Location:
    Live! From New York!
    I read it was removed by the new SDK regulations so DJI forced them to remove it.
     
  3. iowahill

    Joined:
    Sep 6, 2015
    Messages:
    197
    Likes Received:
    22
    Location:
    Roseville, CA
    What are "SDK regulations"? Android platform?
     
  4. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,374
    Location:
    Live! From New York!
    Software Developer Kit for DJI mandated it be removed. Third party apps have to conform to DJI rules.
     
  5. iowahill

    Joined:
    Sep 6, 2015
    Messages:
    197
    Likes Received:
    22
    Location:
    Roseville, CA
    Kinda thought that may be the case after pondering "SDK" and whose it referred to. DJI sure doesn't seem to give a crap about legacy owners and support.
     
  6. Jarkko Sydänmaanlakka

    Joined:
    Apr 7, 2015
    Messages:
    51
    Likes Received:
    13
    Location:
    Vantaa, Finland
    Wery sad :( I really hope that my phone hasn't auto updated my lichi app.... :/
     
  7. EddieR0691

    Joined:
    Dec 10, 2015
    Messages:
    21
    Likes Received:
    0
    Location:
    Oklahoma
    Don't install the beta version! Simple...use the release version and you'll be fine. I think you have to opt-in to even get the beta software. 2.7.1 is apparently the latest/greatest version supporting P2V and P2V+.
     
  8. JCJMC

    Joined:
    Aug 24, 2015
    Messages:
    40
    Likes Received:
    4
    Location:
    Spain
    Is despicable DJ performance to begin not update their applications and end not let others do it. The pity is that no more leading companies in the sector to ensure greater competition not only on prices, if not in performance, perhaps this way DJI would not do what I wanted.