Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Latest issues with batttery software

Discussion in 'Phantom 2 Discussion' started by tom3holer, Nov 23, 2014.

  1. tom3holer

    Joined:
    Mar 20, 2014
    Messages:
    324
    Likes Received:
    2
    Location:
    Cape Cod, Ma.
    Hi,
    I have been away for several months due to work and family matters, Daughter getting married......

    Anyway in trying to get caught up I am confused about the battery bricking issues on the P2

    I have 3 batteries. Two are over 8 months old DJI and one aftermarket one that is 6 or so months old.

    As I read the there seems to be an issue with the older DJI batteries and aftermarket ones that will not work with the latest S/W as it thinks its a non DJI battery.

    Can someone elaborate on this a bit for me?

    Thanks,

    Tom
     
  2. GhostMaster

    Joined:
    Dec 7, 2013
    Messages:
    793
    Likes Received:
    36
    Simple if you update the p330cb to the 1.0.2.8 version you will not be able to use the older 1.6.0.0 firmware batteries.

    The 3.08 firmware works fine, the problem is the firmware that was sent yesterday to the p330cb.

    More info: viewtopic.php?f=19&t=30048