Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Issue Connecting to WIFI with Android

Discussion in 'Phantom 2 Vision Discussion' started by ShawnSmith, Nov 20, 2013.

  1. ShawnSmith

    Joined:
    Nov 19, 2013
    Messages:
    33
    Likes Received:
    1
    I have had no problems connecting my Samsung Galaxy S4 to the Phantom Vision's WIFI until today. Yesterday, I updated all firmware including the RC. I had one flight after the updates and had no issues connecting/using the WIFI with my S4. I took the PV out today and could not get my phone to connect to the WIFI. It tries to connect, then says "Internet Not Available" and disconnects. I tried cycling power on everything(PV, RC, Booster and Phone) and continued to get the same error. I was able to connect with my iPod Touch and fly just fine, but it was supper laggy. Any ideas?
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    For Android phones try the following: go to Settings > Wifi > Advanced and uncheck "Avoid poor connections". This will prevent the phone from dropping the phantom's SSID in order to look for a better one because it can't see the internet when connected.
     
  3. ShawnSmith

    Joined:
    Nov 19, 2013
    Messages:
    33
    Likes Received:
    1
    Thank you! That got me going in the right direction. My particular android version is slightly different. It was Settings > WIFI > Advanced > Auto Network Switch unchecked seems to have done the trick. I can now connect to Phantom Vision wifi. Will test in flight tmrw.
     
  4. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Yes, sorry should have said I have a Nexus 4 running vanilla 4.3 - but we got there in the end!