Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Hovered at 1.2m but controls unresponsive 1st Flight

Discussion in 'Pro/Adv Discussion' started by Philistin, Jul 11, 2016.

  1. Philistin

    Joined:
    Jul 11, 2016
    Messages:
    2
    Likes Received:
    1
    Its the first time I've taken the P3 pro out for a flight, all the calibrations go well and I swipe ok for take off. The P3 rose to 1.2m and just hovered, the sticks are unresponsive, so after a 3-4 minutes I press land. I switched everything of and tried again. When I press take of a little window appears saying that the drone will take off and hover at 1.2m. Help what am I missing - the hand brake ?
     
  2. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL
    Go to stick configuration and make sure custom is not selected. If custom is selected, make sure the controls are actually mapped. That happened once with me. Custom was selected but GO didn't save the stick settings so the sticks were not mapped. Other than that, not sure what to tell you.
     
    Philistin likes this.
  3. GunnyPapa

    Joined:
    Nov 28, 2015
    Messages:
    201
    Likes Received:
    39
    Does the bird take off normal without using auto take off?
     
    Oso likes this.
  4. Wolfiesden

    Joined:
    Jan 12, 2016
    Messages:
    1,187
    Likes Received:
    400
    Location:
    Milwaukee, WI, Ft Walton Beach, FL
    He is probably like I was. I didn't want to manual takeoff until I had some stick time and confidence. And yes, I know takeoff is easy manual. You don't know that at first though!
     
    Digdat0 likes this.
  5. Philistin

    Joined:
    Jul 11, 2016
    Messages:
    2
    Likes Received:
    1
    It was a RC calibration problem, sorted now. Required a firmware update. Thanks for your responses.
     
    GunnyPapa likes this.
  6. GunnyPapa

    Joined:
    Nov 28, 2015
    Messages:
    201
    Likes Received:
    39
    Great to hear you got it resolved!!