Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help please, mini osd not working

Discussion in 'Phantom 2 Discussion' started by leeada, Mar 19, 2014.

  1. leeada

    Joined:
    Mar 7, 2014
    Messages:
    2
    Likes Received:
    0
    Hi all, noob here, I've just bought the fat shark attitude v2 kit, mini iosd and the mini iosd to fpv cable from firstpersonnview, I've installed everything how I think it should be but am getting no osd, the camera feed to goggles is fine though. I've upgraded the iosd to latest fw and all I get is a flashing green light, so the question is.. have I wired it up correctly, do I have a faulty unit, or is the cable not right? I am using the cam provided in the goggle bundle not a go pro. Any help would be greatly appreciated, cheers Lee
     
  2. goldfishrock

    Joined:
    Jan 7, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Devon, UK
    If you aren't seeing any IOSD info then it is either the wiring is incorrect or the IOSD is faulty. The flashing green means that it's receiving data I think.

    Even if you don't have the camera connected to the IOSD, you'd stll get IOSD data being sent back so the camera shouldn't make a difference.
     
  3. tupes

    Joined:
    Jan 25, 2014
    Messages:
    116
    Likes Received:
    0
    Location:
    New Orleans, La
    Have you connected the osd to your computer and updated it? If not you need to do so. That's more than like likely the reason if you have not done so.
     
  4. goldfishrock

    Joined:
    Jan 7, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Devon, UK
    You'd still get some output from the IOSD without the update though.... you just wouldn't get any data.
     
  5. ianwood

    ianwood Taco Wrangler
    Staff Member

    Joined:
    Jan 7, 2014
    Messages:
    4,916
    Likes Received:
    1,792
    Location:
    Lost Angeles
    Agreed, if there is no OSD output at all, something isn't wired correctly.
     
  6. leeada

    Joined:
    Mar 7, 2014
    Messages:
    2
    Likes Received:
    0
    Thanks all, maybe I got the wrong cable ?? I got this one

    http://www.firstpersonview.co.uk/cables ... ransmitter

    perhaps that one is for a go pro camera, and I should of brought this one

    http://www.firstpersonview.co.uk/cables/iosd-mini-cable

    however with that one I fail to see how the transmitter get's power, sureley the small white connector goes to the camera and the larger white one goes into the mini, is another cable needed to go from the transmitter to the cam out on the p2?, i'm so confused :(
     
  7. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,375
    Location:
    Live! From New York!
    I am having the same issue. I am fully updated, flashing light, iOSD icons on screen, no live data. Should I assume it is defective?

    EDIT: The seller has agreed to replace it. Sure hope that is the problem.
     
  8. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,375
    Location:
    Live! From New York!
    I received a replacement iOSD and all works as intended so problem solved, I had a defective iOSD.
     
  9. goldfishrock

    Joined:
    Jan 7, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Devon, UK
    That's good news. It's a real 'weight off' when you finally get something like that resolved :) Happy flying