Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

HELP - Gimbal is limp and lifeless after firmware update

Discussion in 'Firmware' started by benbNZ, Mar 20, 2014.

  1. benbNZ

    Joined:
    Mar 17, 2014
    Messages:
    9
    Likes Received:
    0
    Hi,

    I upgraded the firmware for my Zenmuse Gimbal to v1.8 and followed all the steps in RC Assistant and Phantom 2 Assistant.

    My PT2 assistant now shows no firmware installed (despite saying it had installed correctly) and now my gimbal is limp and unresponsive.

    The upgrade fails every time I try and install it.

    I am in NZ and have just shipped my PT2 out at huge expense.

    Any help would be greatly appreciated.

    Thanks,

    Ben
     
  2. jasperthayer

    Joined:
    Mar 8, 2014
    Messages:
    41
    Likes Received:
    0
    redacted

    redacted
     
  3. TiberiumKANE

    Joined:
    May 7, 2014
    Messages:
    11
    Likes Received:
    1
    Daniel Huang (DJI)
    May 09 15:04

    Dear Sir,

    Please kindly send it in for service.
    The gimbal IMU is missing.

    However, there's a back door way for your problem and I'm not sure if you could pull it off.

    1.As attached, try to wire it up(using a cable or conductor) that two point
    2.Power on your phantom and you might find the light in the gimbal turn red
    3.Connect your phantom with assistant software and there would be a gimbal IMU in the Upgrade tab
    4.Remove the wire and update that IMU
    5.Power Cycle
    If you try, please let me know if it works.

    Best Regards.
    [​IMG]


    Sent from my iPad using Tapatalk