Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

H3 3D Not responding

Discussion in 'Phantom 2 Help' started by pj7, Jun 18, 2014.

  1. pj7


    Jun 18, 2014
    Likes Received:
    Hi Guys,

    Recently acquired a Phantom 2 with the Zemuse H3-3D Gimbal.

    Thought I would follow protocol and about the software after getting everything out and having a test.

    I updated the Gimbal because I noticed it was moving freely and not initialising like I have seen on online tutorials.

    After the upgrade I turned the over on and off but the Gimbal didn't respond. It now just hangs lifeless. I can hear a small amount of noise coming from the gimbal itself and the small green LED is on but still nothing happens.

    I am relatively new to this so if it is something obvious I apologies.

    But any suggestions?

  2. Pull_Up

    Nov 5, 2013
    Likes Received:
    South Oxfordshire, UK
    If it NEVER initialised like you've seen then it sounds like it was dead on arrival. If you installed the gimbal yourself then double-check all connections and use the P2 Assistant to check the gimbal settings, including that the gimbal is turned on within the Assistant. If it's all good then I think you ought to contact your dealer for a replacement gimbal under warranty. If you bought it ready-fitted then I would just go straight to whoever you bought it from to arrange to have the whole thing replaced under warranty as dead on arrival - or at least have them take it back at their own cost to fix the problem.