Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Good GPS signal but wont go home

Discussion in 'General Discussion' started by tnc110, Oct 17, 2013.

  1. tnc110

    Joined:
    Jul 14, 2013
    Messages:
    12
    Likes Received:
    0
    Got the dragon link system setup on the phantom. But when I put into fail safe it does not return home....actually flys away until I take it out of fail safe. No red lights so it has good gps signal. Any ideas?
     
  2. miskatonic

    Joined:
    Sep 11, 2013
    Messages:
    351
    Likes Received:
    0
    Did you set a home location for the Fail Safe to come back to?
     
  3. martcerv

    Joined:
    May 27, 2013
    Messages:
    1,002
    Likes Received:
    2
    Have you set your controller up properly, you should be able to test this in the NAZA assistant. If you turn off the radio does it say failsafe and same with flicking the switch to rth if enabled.
     
  4. tnc110

    Joined:
    Jul 14, 2013
    Messages:
    12
    Likes Received:
    0
    I thought a home location was set every time the machine was plugged in/turned on?

    If not then what is the procedure to set a home location.

    BTW...when it goes into failsafe the led blinks yellow...
     
  5. Imabiggles

    Joined:
    Oct 11, 2013
    Messages:
    299
    Likes Received:
    84
    flip it to homelock during flight and see if it works as expected. If so, it remembers home, you likely have it set to landing for failsafe instead of RTH. If not, please post any resolution you come up with.
     
  6. martcerv

    Joined:
    May 27, 2013
    Messages:
    1,002
    Likes Received:
    2
    Much safer to first test it in the NAZA assistant, when I programmed my Futaba 8FGS I did all testing within NAZA assitant first. I have set GPS, Manual and ATTI modes in a 2 position switch but also a forced failsafe switch that will go to failsafe no matter what mode I am in. If in the assistant and the radio is on it should show all controls and the bottom of screen will tell you what mode you are in as you change these or turn off the radio to test loss of signal.

    Next test you can do is with no props power the phantom and using radio flick through modes, the rear LED should change colour indicating what mode you are in. So 1 green for GPS if sticks centered 2 if not centered same with atti but yellow flashes, if you switch to forced failsafe or turn off the radio then you should get constant yellow flashes indicating RTH failsafe is in operation or there is no radio communication being received.

    If you pass both these tests then do a flight test after making sure you have waited for full GPS lock and also the quick green flashes indicating a home location has been saved. You can always skip the first 2 steps if you want and test failsafe in flight first its your phantom not mine, but Id rather be sure the radio is set 100% as I want before flying it. ;)
     
  7. tnc110

    Joined:
    Jul 14, 2013
    Messages:
    12
    Likes Received:
    0
    ok, so I just did the most recent update and re calibrated tx and compass. failsafe is set at RTH. According to nazza assist when the tx is turned off it goes into failsafe. just took a test flight, turned off tx mid flight and the phantom flys away. went back into assistant and changed my flight mode switch from manual to fail safe. now when i am flying and switch to failsafe with the switch the phantom does complete the RTH function. But once in failsafe I cannot regain control by switching the flight mode switch back to gps. I do regain control after I turn the tx off and back on again.

    Also, when in normal flight and turning off the tx, it continues to fly away.
     
  8. tnc110

    Joined:
    Jul 14, 2013
    Messages:
    12
    Likes Received:
    0
    Im getting somewhere now.

    Just went back into assistant and noticed that the "control mode" block shows the to be in fail safe when tx is off, but the black slider is under the atti block and on the bottom of the screen it says that it is in atti mode, not failsafe. So...how to I get it to go into failsafe with tx off