Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Madpunters

    Joined:
    Aug 29, 2016
    Messages:
    3
    Likes Received:
    0
    Posting this on behalf of a friend with the below problem.

    I made the mistake of trying to upgrade the firmware with DJi app, seemed to go okay but then lost connection between devices about 60% and failed, drone still flew but couldn't connect to camera.
    Downloaded latest software for pc and tried using the DJi Assistant 2 same result upgrade failed this time at 70% error code 0002.

    Any tricks/ links or ideas on how to make the firmware upgrade work or reset to original will greatly appreciated ?


    Sent from my iPad using PhantomPilots
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,850
    Likes Received:
    5,552
    Location:
    US
    Your friend should try the following (in this order until the issue is resolved):

    1) Reinstall the firmware via DJI GO (like this)
    2) Reinstall the firmware via DJI Assistant 2 (like this)
    3) Reset the firmware via via DJI Assistant 2
    4) Get the firmware upgrade log (like this) and contact DJI support for help

    If your friend needs more help, it would be easiest if he/she posted here directly.
     
  3. Madpunters

    Joined:
    Aug 29, 2016
    Messages:
    3
    Likes Received:
    0
    Thanks for your help msinger. Have passed your info on. Hopefully it will fix the issue. Cheers


    Sent from my iPad using PhantomPilots
     
  4. Mus

    Mus

    Joined:
    Oct 8, 2016
    Messages:
    1
    Likes Received:
    0
    Thanks for your help guys,
    Unfortunately still seem to be having problems with firmware.
    I have followed the advice in the links supplied and downgraded the RC to V1.580 and formatted the SD card > started aircraft and RC > connect RC to Ipad Pro, opened DJi Go and wait till upgrade message appears > disconnect from RC and connect to aircraft, the message appears again > download the upgrade and start updating.

    I then get a popup message around 45% saying "Cannot use device" "DJi device not supprted" this message goes away.
    Around 65% I get another popup "Unplug and re-plug data cable to refresh aircraft status" if I ignore this the update gets to 99% without ever finishing.
    If i unplug & re-plug the cable when it asks same result 99% forever.

    Tried updating via DJI Assistant gets to about 50% and displays message "lost connection to device" several times then seems to reconnect before failing around 65% with 0002 error, tried restarting aircraft/ re-entry, just keeps failing.
    I've upload a report from the failed upgrade so hopefully might lead to some answers.
    I think the problem might have started when i inadvertently upgraded the RC first.

    In desperation I tried applying update to RC via the DJI GO, current version is now 01.02.0503.
    Connected to aircraft current version is also 01.02.0503, neither come up with any available updates.

    I calibrated the compass and flew around a bit the problem now seems that the camera works initially then fails with "No Image Transmission Signal"
    Overall Status has a "Air Encoder Error: (0x2800020), suggests restart aircraft again the camera works the fails.

    Any thoughts or is it a job for support?

    thanks again, Mus