Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Damaged Gimbal / Camera

Discussion in 'Phantom 2 Vision + Help' started by Fuji-Flyer, Jan 13, 2016.

  1. Fuji-Flyer

    Joined:
    Mar 31, 2014
    Messages:
    75
    Likes Received:
    0
    Location:
    Southern UK
    I have obtained a crashed P3V+. The bird flies OK after battery was charged and radio re-sync. The Gimbal had come apart and the ribbon cable broken, replaced but all I get is a constant Red Light no gimbal movement. Checked the connectors all in firmly, so it may be the Gimbal PCB which is defective.

    Anyone know how to test or eliminate the parts.?

    Also no Camera wifi as far as I can see.
     
  2. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    if you get a red light it's one of two, main board or cable.
    which cable did you use? original DJI?
     
  3. Fuji-Flyer

    Joined:
    Mar 31, 2014
    Messages:
    75
    Likes Received:
    0
    Location:
    Southern UK
    Thanks for reply, ribbon cable was from eBay UK sourced looked good with firm connectors. When you say main board I assume you are referring to the PCB in the Gimbal case?
     
  4. Fuji-Flyer

    Joined:
    Mar 31, 2014
    Messages:
    75
    Likes Received:
    0
    Location:
    Southern UK
    Also its a P2V+ typo on my original....
     
  5. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    yes, the PCB in the gimbal.
    always use genuine cable from DJI. i can't tell you how many i have tested with no success.
     
  6. Fuji-Flyer

    Joined:
    Mar 31, 2014
    Messages:
    75
    Likes Received:
    0
    Location:
    Southern UK
    Thanks will replace and see the result.