Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Controller signal problem with 2.4ghz transmitter FC40

Discussion in 'FPV (First Person View)' started by Jimfreestyle, Jul 9, 2015.

  1. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    Hi everyone. I recently installed a 2.4ghz boscam FPV transmitter on my phantom FC40 I have a 5" screen with a built in 2.4ghz receiver along with a gro pro 3 sending the signal down.. Now to the issue...! I flew it earlier today and my phantom kept going into fail safe mode and I nearly lost control a couple of times with 2 red blinking lights on the led I quickly switched in to ATTI mode and bought her down to safety. Does any one know what the problem would be? I purchased the 2.4ghz transmitter as I know the fc40 controller runs on 5.8ghz so I was trying to prevent things like this. Any help would be amazing. From a not so confident pilot ! ;(
     
  2. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    How about an update on your issue. Are you still up the creek without a paddle?
     
  3. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    Ahhhh yes it's been sorted now. The problem was that I was told on a forum that the FC40 control run at 5.8ghz because the camera that came with it was 2.4ghz but that was not true the controller is also 2.4ghz so I scrapped me 2.4ghz fpv and purchased a 5.8ghz all runs smoothly now. Thanks for the concern my friend :)
     
  4. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    I don't think you have a FC40 then.

    I have both the FC40 and the P1.

    The FC40 runs on 5.8 control. That is a "For sure truism". I run the WiFi on the gopro which is 2.4... All has been well like that for almost a year.

    I also have a P1 and the control on that bird is 2.4, so my FPV setup is 5.8.

    Take a look on the belly of your bird. Sounds like someone did a control frequency swap, not easy or cheap, but possible. OR you've got a P1. They are virtually the same machine, minus control frequency.

    Glad to hear you've got it sorted out... :D
    I'm concerned that you think you got bad info somewhere. I would like to help you sort out which bird you have. My nickle says it's a P1. :)
     
  5. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    It's had a NAZA v2 in it though and it came with the 2.4ghz camera that you get with the fc40 ... ?
     
  6. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    I'm really confused now lol.. I purchased it new and it was sold as an FC40 I did get the little camera with it which I never really used as I planned a full FPV set up
     
  7. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    Any thoughts ?
     
  8. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    It was this message I was referring to my apologies
     
  9. Jimfreestyle

    Joined:
    Jun 21, 2015
    Messages:
    70
    Likes Received:
    9
    So I have figured it out, the P1 and FC40 are basically the same drone except the earlier P1's have the NAZA V1 inside.

    I have the FC40 but basically DJI paired the wrong controller with it so it's running at 2.4ghz it's not a problem as I've hooked up a 5.8ghz FPV now anyway so no fly always heading my way.

    Anyway thanks for the help everyone.

    Jim