Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't enable IOC

Discussion in 'Phantom 2 Vision + Discussion' started by plasmo, May 15, 2014.

  1. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    I just switched my controler to NAZA mode, but for some reason cannot switch IOC on.

    Whenever I try to enable IOC by clicking the box, the checkmark disappears when I move to another part of the program.


    Anyone know what is wrong? thanks
     

    Attached Files:

  2. dannytroy

    Joined:
    Apr 6, 2014
    Messages:
    186
    Likes Received:
    2
    Location:
    Westchester County, New York
    I believe you're still in Phantom mode. The tab at the top shows the mode you want to switch to, not the mode you're in. A little odd, but I think that's the way it works.
     
  3. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0
    No, I was able to switch to Naza. I'll check it again when I get home


    Sent from my iPhone using Tapatalk
     
  4. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    No. It shows what you are on.

    Op, what is that exclamation mark in bottom right telling you? You have the phantom connected and turned on yes?
     
  5. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    While on the page, move the toggle switches and you should see home lock and course lock confirmed (or not) on the bar below.
     
  6. Woody

    Joined:
    Mar 17, 2014
    Messages:
    212
    Likes Received:
    31
    I had the same problem, got a popup warning me something about GPS not right. And IOC wouldn't stay enabled. Turns out that my Phantom was sitting on a table with something metal interfering with GPS. Moved it over a few inches and the warning disappeared and IOC stayed enabled. :D
     
  7. plasmo

    Joined:
    Apr 20, 2014
    Messages:
    183
    Likes Received:
    0

    YES - This fixed it. THANKS.
    I moved the Phantom away from my computer monitor as far as possible (the supplied USB cord is not very long to begin with)
    and the Exclamation icon disappeared, and then I could activate IOC and it responded with the S2 switch, so now I have Home Lock enabled. THanks again!
     
  8. Woody

    Joined:
    Mar 17, 2014
    Messages:
    212
    Likes Received:
    31
    You're welcome Plasmo, I was hoping that's all it was.

    I'm thrilled to finally have IOC, had to wait for the Mac version to come out for the FC40 and Phantom 1.
     
  9. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    It's so useful it really should be less intimidating to switch it on.

    Course lock is excellent for flying in a straight line while gently rotating to keep something centred which you are passing, home lock can be used to circle your location while facing inwards, again very useful apart from the obvious ability to come straight towards you from any direction.