Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery Question

Discussion in 'Phantom 1 Discussion' started by DaWife, May 4, 2014.

  1. DaWife

    Joined:
    Apr 18, 2014
    Messages:
    35
    Likes Received:
    1
    We're trying to charge the Phantom's 1 batteries again and can't seem to get them to charge. S1 light flashes then the main light flashes with S2 & S3 lighting faintly (maybe a reflection of the main light?) Both batteries are doing the same thing. One has been on for hours and we just tried the 2nd. The pic below shows the main light flashing.

    [​IMG]

    The toggle switch is on LiPo and the charge is set at 2A and the connection on the side is 3S.

    What are we doing wrong?

    DaWife
     
  2. DeweyAXD

    Joined:
    May 31, 2013
    Messages:
    818
    Likes Received:
    9
    Location:
    Oxfordshire, UK
    Sounds like you are doing all the right things... but these are not exactly 'hight quality' chargers and a fair few have been known to go wrong (maybe a capacitor inside has puffed).

    There is no real trick just make sure you have Lipo selected and frankly anything on the amp slider is fine (3a is fine on those stock batts). Then a case of balance plug into the slot (where it should register 1s, 2s and 3s lights to show it knows its a 3s) and then plug the XT60 in.

    If that doesn't work then it is likely a duff charger but worth getting a voltometer on the battery and make sure its not totally discharged (as the charger won't revive it).

    Accucell 6 from Hobby King is a good replacement if you want more info on how much power you are putting back into your batteries between flights (handy if you want to mess with voltage limits)... either that or just buy another one from a DJI dealer.
     
  3. kydan

    Joined:
    Feb 23, 2014
    Messages:
    440
    Likes Received:
    2
    Location:
    Chattanooga, TN
    I have the Thunder AC6 charger. You will certainly want a better charger than the stock one. My stock charger would not charge the batteries fully according to itself. It never got to the complete status. I bought a XT60 connector for my AC6 charger and it balance charged them perfectly.