Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Antiquated Smartphone compatibility

Discussion in 'Phantom 2 Vision Discussion' started by pawnmeister, Feb 1, 2014.

  1. pawnmeister

    Joined:
    Jan 30, 2014
    Messages:
    32
    Likes Received:
    0
    Based on the lists I see on the forum I guess its safe to say my Droid X is not compatible for FPV. Running Android 2.3.4, I get an "unable to parse package" when attempting to download Dji software. Ugh...didn't anticipate a phone upgrade investment with this craft but Galaxy S4 here I come. Am I missing something obvious with this dilemma? thanks
     
  2. iResq

    Joined:
    Dec 23, 2013
    Messages:
    545
    Likes Received:
    2
    Location:
    Annapolis, Maryland
    Yes the awesome S4. Search Samsung as there is a wifi setting unique to Samsung that will need selected.

    Sent from my DROID RAZR using Tapatalk
     
  3. pawnmeister

    Joined:
    Jan 30, 2014
    Messages:
    32
    Likes Received:
    0
    iResq,
    Thanks for the response...I already have one, lightly used coming from eBay. Is the Samsung website the best place to find more info on the needed Wi-Fi settings? thanks again!
     
  4. gbshovel

    Joined:
    Dec 15, 2013
    Messages:
    212
    Likes Received:
    1
    Location:
    Conneaut Ohio
    That just the S 4 ??
    My S III connects just fine?
     
  5. iResq

    Joined:
    Dec 23, 2013
    Messages:
    545
    Likes Received:
    2
    Location:
    Annapolis, Maryland
    There is a setting in wifi about trying to find best signal that is on be default. As such the phone my try to switch networks of it finds one with a better signal. I'm not sure which Samsung devices has this feature.

    Sent from my DROID RAZR using Tapatalk