Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Android video laaaaaag still after update

Discussion in 'Pro/Adv Discussion' started by DJJI, Sep 8, 2015.

  1. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    My Samsung s5 and Samsung tablet s is still lagging big time after the new update!
    I have a task killer, switch on airplane mode, closing all programs.
    It dosent work!

    I`m also using an ipad air 2 that works perfect no problems.
    How is it that DJI still haven`t figured this out yet?

    I`ve also printed a part for the TX so I can extend the length of the dji TX holder so it can fit my samsung tab s.

    And I cant find any over exsposure warning on android:(
     
    #1 DJJI, Sep 8, 2015
    Last edited: Sep 9, 2015
  2. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    Anyone having lags after updating to latest firmware?
     
  3. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,554
    Likes Received:
    1,397
    Location:
    Salt Lake City, UT
    No lag using my Nvidia Shield. Dump the task killer, restart prior to the flight and turn the video feed down to 4mb/s. See what happens.
     
  4. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    okay thanks, can you please guide me to turn the video feed down?
    Thanks
     
  5. DMac

    Joined:
    Feb 1, 2015
    Messages:
    118
    Likes Received:
    15
    I have the Samsung galaxy tab 10.5. I am not experiencing lag anymore. After MUCH review on this forum and other research, here's what I did:

    1. Rollback google play services. Do this by going into apps. Choose google play services. Select uninstall updates. Then select disable.

    2. Under settings, I select the option that allows for two or less background processes to be running.

    3. Go into airplane mode.

    4. In the DJI GO app, turn cache video to the off setting.

    Really, this is working well for me. Let me know how it goes for you, and I will try to help in anyway I can moving forward.

    Best to you,
     
  6. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    Thanks for your nice answer DMac, I tried to roll back the google play service on time, but all the apps gets crazy I get notifications that things don`t update for example.
    What is cache video? Is that for loading the maps only before you go fly? Where do I turn this off?

    I think I want to try to turn the video feed down to 4 Mbit/s but I don`t know where to do that?

    I think it`s pretty strange DJI haven`t fixed this issue, when the IOs works so good, also I cant`t understand why they haven`t put over exsposure warning in there for android...

    Thanks
     
  7. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    I too have tried to downgrade google services but as wrote from djji is impossible to live with that, too many issues generated. Instead of doing this, i've update google services to a version that is not yet available on playstore and after a small test in house seems working fine (i've to test outside).

    Imo the play services issue is generated by version 7.8.99. Check the version you're using
     
  8. DMac

    Joined:
    Feb 1, 2015
    Messages:
    118
    Likes Received:
    15
    Let me give you the step-by-step process.

    To disable the video cache do the following:
    - with the quad copter on in Cameraview on the DJI GO app, select the three dots to the lower left. This is the "OTHER" menu. It is the same one with the quad copter in the upper left followed by the remote followed by HD, the chevron icon for the quad copter direction, and the camera gimbal. Under the video cache section toggle the button located to the right to where no green is displayed. This disables video caching. To be honest, I do not know what functionality I give up in doing this, but I do know my video lag is as it should be.

    To limit the background processes on the tablet do the following:

    - settings
    - General
    - developer options
    - scroll to the bottom where you will find the APPS section. The second option is "limit background processes". By selecting this you can change the options. I have mine set at two processes at most.

    Give this a try. Of course, I also put the tablet in airplane mode. Maybe you won't have to disable Google play services.

    Let me know how it goes.

    Best to you.
     
    Jeff likes this.
  9. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    Hi, I`ve turned off the video cache, and set max background processes to two like you had and airplane mode on.

    On the samsung s5 phone it works for a coupple of minutes and then fails like 2-3 secounds lag or full stop for 10 secounds or more.

    The samsung galaxy tab s is useless even tough I did the same things with this as I did on the phone.

    StevenQX how did it go?
    If it worked can you explain how you updated to a new version or what you did?


    Thanks everybody.
    Here is a video I made today;)

    Will be available in 4k when youtube have uploaded completely.
     
  10. AlmostTan

    Joined:
    Jul 22, 2015
    Messages:
    164
    Likes Received:
    65
    Location:
    San Diego
    I don't know that the lag is any fault of DJI's. It's clear that the lag becomes more prominent and unusable after the devices are heating up.
    Unfortunately, compared to iOS - Android devices will always generate more thermal energy (faster processors due to non-native compiled code) than their iOS counterparts and then experience throttling. Even one of the most popular fixes, rolling back play services, has to do with the way the OS works and has little to do with DJI.
     
  11. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,981
    Likes Received:
    1,122
    Location:
    Yorba Linda, CA
    Hey djji, Have you tried enabling hardware encoding?
     
  12. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    Hi John Locke
    I haven`t tried hardware encoding, what is that? and how can I do it?
     
  13. AlmostTan

    Joined:
    Jul 22, 2015
    Messages:
    164
    Likes Received:
    65
    Location:
    San Diego
    That's for iOS devices.
     
  14. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    I don`t think I need to do that then, I don`t have problems with IOs, only android.
    Now I`m thinking of getting litchi instead and try that. Semms like a better app or?
     
  15. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    I wish someone could tell me how to choose 4Mbit/s instead of what I have, but I don`t knnow where to do that. Think that might be the last thing I will try, if that dosen`t work I might switch to litchi
     
  16. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    You should open the HD video settings page (where you see the graph with signal levels of ) in GO app when you are connected with your phantom. Then enable manual channel selection and scroll down. There is a slider where you can select the bitrate/distance you want.
    But I am not sure if it stays if you go back to automatic channel selection. If you fly in area where there some wifi active, it would be better to fly in auto mode.
    I tried one time 4 Mbps but it didn't make any difference for me.
     
  17. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    okay, I guess I will give it a try for fun. Thank you:)
     
  18. louforgiveno

    Joined:
    Jan 16, 2015
    Messages:
    644
    Likes Received:
    251
    Djji, i know that with the play service rollback the os gives message that maps won't work etc, but i updated all the google apps then rolled back google play service and although it gives me that message maps still opens and works fine....gmail doesn't (asks for update). In my case my tab S is just for my phantom so i don't need gmail to work. So if you really want the best experience you might want to retry the rollback....and btw you can rollback just to fly (takes seconds) and then re-update for "home" mode.
     
    DMac likes this.
  19. DJJI

    Joined:
    Jul 10, 2015
    Messages:
    190
    Likes Received:
    16
    I know that might be a solution, but I think it`s a principple.
    DJI says that the app works with thoose devices and then it should.

    How do you roll back google play? Can you please tell me step by step?
    Thanks again;)
     
  20. Spry25

    Joined:
    Aug 20, 2015
    Messages:
    10
    Likes Received:
    5
    Unfortunately, unless you rollback/downgrade Google services you are going to continue to get lag. I agree that it shouldn't be this way, but it is.