Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Alternative android app

Discussion in 'General Discussion' started by colinzzr, Nov 14, 2014.

  1. colinzzr

    Joined:
    Nov 13, 2014
    Messages:
    5
    Likes Received:
    0
    Hi fellows pilots, I have a Samsung galaxy tab 2 10.1
    My problem is that the DJI android app is not compatible
    Is there an alternative I can download so I can view my Phantom 2 vision plus
    Thanks Colin
     
  2. paulajayne

    Joined:
    Sep 1, 2014
    Messages:
    330
    Likes Received:
    22
    Location:
    Bocking - England
    App works fine on my Tab 2 10.1 - where did you download it from - got mine from the app store.
     
  3. Cyclone

    Joined:
    Feb 1, 2014
    Messages:
    549
    Likes Received:
    130
    Location:
    Essex, UK
    crane-man likes this.
  4. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    May need change a setting to allow install from other sources
     
  5. colinzzr

    Joined:
    Nov 13, 2014
    Messages:
    5
    Likes Received:
    0
    My galaxy tab 2, is one of the 1st quad core processor about 3 years old, and when I try to download it
    From the app store or DJI, I get the message incompatible with this device
    Any other suggestions ?
     
  6. colinzzr

    Joined:
    Nov 13, 2014
    Messages:
    5
    Likes Received:
    0
    Thanks everyone I have tried Cyclone link and it's worked

    Happy Days
     
  7. Cyclone

    Joined:
    Feb 1, 2014
    Messages:
    549
    Likes Received:
    130
    Location:
    Essex, UK
    :)

    Enjoy ur flying.
     
  8. fizzviic

    Joined:
    Aug 17, 2013
    Messages:
    265
    Likes Received:
    0
    Do you know how to "sideload" an APK? If so, get the APK for the new app from the web. Hook your device to your computer, find the correct file location and transfer the APK to that location and you should be fine.

    My Nexus 7 gave me the "non compatible" message as well. Works just fine now.
     
  9. colinzzr

    Joined:
    Nov 13, 2014
    Messages:
    5
    Likes Received:
    0
    Cheers Fizzviic will remember that one
     
  10. crane-man

    Joined:
    Nov 7, 2015
    Messages:
    12
    Likes Received:
    5
    Thanks this worked on my tab 2 , cheers