Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Wild accelerating front engines

Discussion in 'Phantom 2 Help' started by Robertch, May 30, 2014.

  1. Robertch

    Joined:
    May 30, 2014
    Messages:
    2
    Likes Received:
    0
    I recently changed the entire circuit board on my Phantom two. Everything seems ok until I accelerate to take off and the two front engines accelerate wildly out of control. as a result obviously it will not fly. Can anybody please help identify this problem and if there is a fix?? Thank you.
     
  2. KG4MXV

    Joined:
    Mar 29, 2014
    Messages:
    198
    Likes Received:
    1
    Did you change any of the wiring of the motors. Are they rotating in the correct directions?

    If so then it sounds like there is control fault swap the two front ESC's with the back and see if the problem
    goes to the back. If so then you have a problem with the ESC's

    what happened to the old Main control pcb?
     
  3. Robertch

    Joined:
    May 30, 2014
    Messages:
    2
    Likes Received:
    0
    I burnt out the FPV diode on the old PCB. I continued to use the phantom without any problem. The diode for the FPV was the only thing that was wrong!! I don't believe I have returned any wires wrong they are as they came off!!
     
  4. Dalite

    Joined:
    Jan 19, 2014
    Messages:
    159
    Likes Received:
    1
    Location:
    Brunswick, GA. USA
    The order in which the ESC cables go into the NAZA may not be correct,