Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Weak gimble magnet?

Discussion in 'Pro/Adv Discussion' started by jabk0912, Sep 25, 2016.

  1. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    Im curious if this a thing? After gettig the crazy gimble wiggle, where i needed to take the back cover off and make sure that the post had the flat piece straight across, it seems that, while flying, it will start to get a crooked horizon.

    Then ill have to straighten it again. Also, it seems as if the front part, that normally would tear the ribbon when it comes off, has been slidding off with alot more ease then before.

    Is there a suggested way to go about this? Its been extremely frustrating.

    thanks in advance
     
  2. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    972
    Likes Received:
    155
    Location:
    Florida
    Can u upload some photos so we know exactly what and where. If it is the roll ring that goes around the back of the motor, I use red loctite
     
  3. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    You can just pull it right off. Seems like I'm missing something, or clearly not doing something right! Aha
     
  4. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
  5. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
  6. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    972
    Likes Received:
    155
    Location:
    Florida
    that is not good dude. I use red loctite on the shaft end that goes in the hole. Just a touch. Make sure the flat is correct. Let it set for a day before u fly.
     
  7. DPD

    DPD

    Joined:
    Jan 31, 2016
    Messages:
    144
    Likes Received:
    20
  8. jabk0912

    Joined:
    Jan 26, 2016
    Messages:
    34
    Likes Received:
    1
    I've seen that, which I agree. May be worth the 50 bucks.

    With the loctite, you put it on the end towards the camera? I haven't done that yet....

    Sent from my SM-G935V using PhantomPilots mobile app