Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Tarot T-2D first flight(Really shaky).

Discussion in 'Phantom 2 Discussion' started by sxmdrones, Apr 30, 2014.

  1. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Hi Guys, I have installed the Tarot T-2D gimbal on my phantom 2. For some reason the gimbal is not doing what it should be doing and the video looks so shaky its as if no gimbal has been used. Can anyone advise what I should do? I have not connected the tilt function yet.
     
  2. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    Mine works perfect. Have you calibrated it? Does it look fine when you are just holing it?
     
  3. ElGuano

    Joined:
    Sep 4, 2013
    Messages:
    2,219
    Likes Received:
    4
    Have you read up on microvibrations? Is that what you're seeing? Or is this some other type of oscillation/shake?
     
  4. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    i have not calibrated it yet and never used the gyro to program it as i did not use the tilt yet. Its just assembled and attached to the bottom of the P2 with two screws. There are five screw holes below the P2, I used the center hole as my front screw and drilled another hole right below battery adjacent to the center hole to attach the gimbal. The video is being uploaded now and will post the link when its ready.

    This is how mine look
     

    Attached Files:

  5. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    same way mine is installed. but I dont have vibration.
     
  6. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Booszey, did you calibrate it after install?
     
  7. Boozshey

    Joined:
    Feb 1, 2014
    Messages:
    274
    Likes Received:
    1
    Yes, both of the ones that I have owned I have had to calibrate. They were jerky and/or just rolling... I also turned the tilt on at the same time.
     
  8. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Here is the video taken right after installing the Tarot T-2D v2 on my Phantom 2 with a GoPro Hero 3 Black edition.

    [youtube]http://www.youtube.com/watch?v=qM6CVy833zw[/youtube]
    http://youtu.be/qM6CVy833zw
     
  9. ElGuano

    Joined:
    Sep 4, 2013
    Messages:
    2,219
    Likes Received:
    4
    OK that is really bad. Your gimbal isn't even stabilizing the roll.

    Have you upgraded the motors and controller to v1.5? That takes care of most microvibrations. Everything else should be fixable via PIDs, post a screenshot of the settings you're running.
     
  10. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    No, I haven't upgraded any firmware on my Tarot T-2D v2. Will post screenshot here once i get to program it.
     
  11. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Here is the screenshot of my Tarot settings, I have just upgraded it to firmware v1.5



    I have also tried to attach the tilt to the Naza according to this method but when i turn the tilt on back of my phantom controller the Tarot gimbal doesn't move. Any ideas why?
     

    Attached Files:

  12. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
     

    Attached Files:

  13. ElGuano

    Joined:
    Sep 4, 2013
    Messages:
    2,219
    Likes Received:
    4
    From your video, it doesn't even look like your gimbal is on. When you power up your Phantom, can you hold it in your hand and see if the gimbal is actively stabilizing?

    The gains you posted are standard, nothing weird that I can see there.

    Re. tilt, I think some people have said the tilt control via F2 may not work with the P2 Naza. I can't test this myself, but that'd be a good thing to confirm before getting too far into the weeds.
     
  14. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    when the gimbal is powered on, its trying to stablize the camera but for some reason it seems like it doesn't know when it is level and keeps on moving up and down.

    On the Phantom 2 Assistant Software, both v2.00 and v3.00 won't allow me to change any settings when i tried to look for option to enable the tilt function from the controller. They both kept saying i need to upgrade my firmware. My current firmware is still v1.08
    I don't see any option to enable/disable the tilt function from the controller on my Assistant Software.
     
  15. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Never mind about the issues related to Phantom Assistant Software v2.0 and v3.0. I realized I used wrong versions of software and now downloaded the Phantom 2 Assistant Software v1.08 and I can change my settings and also see my gimbal switch is on and showing tilt movements.
     
  16. ElGuano

    Joined:
    Sep 4, 2013
    Messages:
    2,219
    Likes Received:
    4
    It may help if you can show a video of what your gimbal is doing in operation. Point a camera at it, power up the P2, and move the quad around so we can see how it's reacting.
     
  17. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Here is the video of the gimbal shaking right after powered on. This is what it is doing. Very weird. The quad is not moving but the gimbal moves erratically.

    [youtube]http://www.youtube.com/watch?v=FUcWQd-vl6s[/youtube]
     
  18. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    Here are my motor settings and the gimbal controller settings:





    Tried all day to get this to work but it still doesnt work properly. Its so frustrating..
     

    Attached Files:

  19. sxmdrones

    Joined:
    Apr 19, 2014
    Messages:
    23
    Likes Received:
    0
    For people who are struggling with their brand new Tarot T2D gimbal on their Phantoms and tried everything to make it work but can't seem to get it work. People whose gimbals moving erratically when powered on without any input. Here is finally a solution before you feel like smash it hard against the wall and turn it into gazillion pieces.

    If you tried upgrading your gimbal controller and motor fimwares to latest 1.5 and that doesn't help.
    If you tried re-wiring your tilt, your roll, and your F2 & F1 channels on NAZA and that doesn't help.
    If you tried changing your gimbal settings in your Phantom Assistant Software and that doesn't help.
    If you tried to calibrate your sensors dozen or hundred of times and still doesn't help.
    If you tried changing all your PIDs in your roll settings, your tilt settings, your angle limits, your RC sentivities, motor reverses, your sensor module mount and basically everything thats changeable within the ZYX-BMGC software and still none helped.
    If you tried asking for help and seems like no one is able to help you.
    If you feel ready to turn the gimbal into ashes...

    Here is a solution for you, the solution is now FOUND! :) No more endlessly searching for clues. No more hours and hours and hours wasted trying to get your gimbal to work. I NOW have the answer to that. That answer is now FOUND! Message me for details!
     
  20. bmw330vasilis

    Joined:
    Apr 10, 2014
    Messages:
    29
    Likes Received:
    0
    Re: Απ: Tarot T-2D first flight(Really shaky).

    hello...
    can you send me the solution?

    thanks

    Στάλθηκε από το GT-I9505 μου χρησιμοποιώντας Tapatalk