Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Signal / Reception Issues (AVL58 + Black Pearl)

Discussion in 'FPV (First Person View)' started by cameracoughlin, Oct 7, 2014.

  1. cameracoughlin

    Joined:
    Aug 11, 2014
    Messages:
    3
    Likes Received:
    0
    Hello fellow pilots!

    I'm writing to all of you again in hopes of having someone bestow some skills and knowledge on an FPV issue I am having.

    PHANTOM SETUP

    +The Zenmuse H3-3D is rigged out with my Hero 3
    +DJI Phantom 2

    BLACK PEARL SETUP

    My AVL58 Receiver has an RX antenna and has a 1/8inch to RCA going in to a YELLOW RCA cable, which is connected to the AV IN on my Black Pearl

    Everything is set to NTSC and even after cycling through all channels, I just can't seem to get a clean signal on my black pearl. If I have everything set up in my office and power up as if ready to fly, my signal is clean. Once there is any flight involved, I get a lot of static and bad reception. Does anyone have any ideas for trouble shooting? Do you know if I can have the black pearl receive the transmission and take out the AVL58 AV-IN setup on my controller?

    Thanks! :)
     
  2. KLEM

    Joined:
    Oct 7, 2014
    Messages:
    2
    Likes Received:
    0
    Isnt the black pearl a diversity receiver?
    Why would you need to use the AV in, just install the two antennas ontop and set it to diversity mode
    I have the same setup and did have a few issues but they seem to have been sorted with the use of some
    higher quality gain antennas :)
     
  3. MarinerSax

    Joined:
    Oct 11, 2014
    Messages:
    14
    Likes Received:
    0
    Hi there -

    I have the same setup as you and it didn't dawn on me until after some web research. Go into the Black Pearl menu (press power button when monitor is on) and change the "Band" to "E". Then, when all your gear is on, press the + / - buttons until you get an image on the monitor (your channel on the Black Pearl matches the channel on the AVL58 Tx). That is how you can use the Black Pearl without the AVL58 receiver.

    However, I am having poor signal / image quality issues with my setup right now. Using stock antennas. Just started to troubleshoot.