Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

short circuit

Discussion in 'FPV (First Person View)' started by Niro69, May 28, 2014.

  1. Niro69

    Joined:
    May 28, 2014
    Messages:
    8
    Likes Received:
    0
    Hi!
    Lost my video stream due to what I Think was a short Circuit in the auxiliary Power. Brown/red feeding the AVL58.
    Anybody with similar experiance and/or have some sulotion to the problem. Using a Phantom V2, GOPRO, gimbal h33d, AVL58.
     
  2. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,257
    Likes Received:
    1,619
    Location:
    Palm Beach Co.- FL
    Why do you suspect a short?

    Do you see damage?

    Do you have a volt meter to test with?
     
  3. Niro69

    Joined:
    May 28, 2014
    Messages:
    8
    Likes Received:
    0
    see no voltage and had a suspect sparkling sound when I change the transmitter
     
  4. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,257
    Likes Received:
    1,619
    Location:
    Palm Beach Co.- FL
    You need to look inside the P2 next to the PCB connector for the camera.

    There have been several occurrences of this and if it is the same as seen before then it is likely you'll see the damaged part.
     
  5. Niro69

    Joined:
    May 28, 2014
    Messages:
    8
    Likes Received:
    0
    did some screwing and find this. seems like the shor Circuit was on the video Cable:) any suggestions?
     

    Attached Files:

  6. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,257
    Likes Received:
    1,619
    Location:
    Palm Beach Co.- FL
    That's what I was talking about.

    If you look around here you'll see others have had this issue.

    The only repair I can suggest is replacement of the board.

    There are those here who say they are going to do this or that to repair or workaround the problem but I have not yet read or heard any success stories.

    The new board is about $70 USD.
     
  7. Niro69

    Joined:
    May 28, 2014
    Messages:
    8
    Likes Received:
    0
    ok, thanks. will order a new one.
     
  8. Mau

    Mau

    Joined:
    Dec 14, 2014
    Messages:
    1
    Likes Received:
    0
    Hi, today I installed the AVL58 transmiter, and in the start, occurs me the same short circuit of your picture.
    How did you resolve it?
    Is it possible to replace the part?
    Thank you.