Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom give issue after reassembly

Discussion in 'General Discussion' started by scpalmetto, Jun 29, 2014.

  1. scpalmetto

    Joined:
    Jun 28, 2014
    Messages:
    10
    Likes Received:
    1
    Will the Phantom 2 Vision Plus power on properly without the camera attached?
    My Phantom 2 Vision Plus fell into a lake. After packing the unit in rice for a week and then reassembling my Phantom 2 Vision Plus the unit gives a red blinking LED.
    (http://s656.photobucket.com/user/southc ... 1.mp4.html)

    Any advice on troubleshooting this and finding out what's causing the issue?
    Thanks for any advice you can give on this issue.
     
  2. scpalmetto

    Joined:
    Jun 28, 2014
    Messages:
    10
    Likes Received:
    1
    UPDATE:
    After plugging this Phantom 2 Vision Plus into my PC the DJI assistant software shows status Voltage: 12399 mV & Current: -418 mA
    I plugged new Phantom 2 Vision Plus into my PC and the DJI software show a status of Voltage: 12292 mV and Current: -970 mA

    Does anyone know the proper range for the Voltage and what the Current should show for this :?: The Voltage looks too low for the old Phantom.
    Thanks again.
     
  3. mb_guy

    Joined:
    May 5, 2014
    Messages:
    91
    Likes Received:
    0
    Location:
    Winnipeg, MB. Canada
    Not sure , voltage is 12.39 versus 12.29 can't see that being a big deal. Current draw is lower on the old one likely indicating some circuit isn't powering up, perhaps something fried when hitting the water. Not sure how we get minus mA on either, software disply issue I guess.