Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 won't lift off the ground

Discussion in 'Phantom 2 Discussion' started by jrwycuff9, May 30, 2014.

  1. jrwycuff9

    Joined:
    May 30, 2014
    Messages:
    4
    Likes Received:
    0
    After flying my phantom 2 for about a week using factory phantom mode, I decided to switch to naza mode to test out the features. I read the manual before switching, went through the start up procedure and proceeded to take off but failed to lift off the ground. With the stick pushed up all the way, it seemed like it didn't have enough juice to take off. I made sure the battery was fully charged and repeated the process only to get the same results. I even switched back to phantom mode and re calibrated the RC to see if that would fix it and the problem still exists. Is there any thing else i should check using the assistant software or could this be a mechanical problem?
     
  2. xgeek

    Joined:
    Jan 20, 2014
    Messages:
    543
    Likes Received:
    0
    Location:
    London, UK, Declination -1.2
    Have you tried calibrating the controller in the RC assistant and then again in the Phantom assistant?
     
  3. jrwycuff9

    Joined:
    May 30, 2014
    Messages:
    4
    Likes Received:
    0
    Yeah, I just tried that and checked over all the settings on the assistant software. It still wont lift off the ground. I still have it in phantom mode and have made no changes to the gain and all my software is updated.
     
  4. xgeek

    Joined:
    Jan 20, 2014
    Messages:
    543
    Likes Received:
    0
    Location:
    London, UK, Declination -1.2
    Are you in mode 1 with the throttle on the right stick?
     
  5. Kelso Kubat

    Joined:
    Oct 12, 2013
    Messages:
    299
    Likes Received:
    0
    Location:
    Frisco, CO
    what are your gain settings? did you try defaulting?
     
  6. bigthai

    Joined:
    Mar 21, 2014
    Messages:
    15
    Likes Received:
    0
    Samething happened to me. I didn't noticed the settings changed to Mode 1 while playing with the assisant software. Just change it to Mode 2 if you want throttle on the left side.
     
  7. jrwycuff9

    Joined:
    May 30, 2014
    Messages:
    4
    Likes Received:
    0
    I'm in mode 1 and I never made any changes with the gain, but I clicked the default button just to make sure and it still wont fly.
     
  8. xgeek

    Joined:
    Jan 20, 2014
    Messages:
    543
    Likes Received:
    0
    Location:
    London, UK, Declination -1.2
    So if you are in mode 1 you are using the right stick to take off?
     
  9. jrwycuff9

    Joined:
    May 30, 2014
    Messages:
    4
    Likes Received:
    0
    that is correct
     
  10. xgeek

    Joined:
    Jan 20, 2014
    Messages:
    543
    Likes Received:
    0
    Location:
    London, UK, Declination -1.2
    ****. I haver no idea then lol
     
  11. bigthai

    Joined:
    Mar 21, 2014
    Messages:
    15
    Likes Received:
    0
    Propellers on correctly? Black cap goes to black dot motors.
     
  12. Karl666

    Joined:
    Mar 31, 2014
    Messages:
    38
    Likes Received:
    0
    Location:
    UK
    seems like I'm having exactly the same problem. No matter how much throttle I give it there doesn't seem to be enough revs or power to lift the craft in the air. Its almost like its hit some sort of rev limit. The motors are not running as fast as per normal albeit they are responding when the throttle is increased. I've run out of things to try :cry:
     
  13. Bog

    Bog

    Joined:
    Jan 3, 2015
    Messages:
    10
    Likes Received:
    0
    i have the the same problem tonight ,
    it happened to me tonight , what was your solution
     
  14. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Try what xgeek suggested.
    Please be aware that there are 2 steps in calibrating. One is for the controller and the other for the phantom. Both must be done.

    Start RC12. You need to plug the usb into the bottom of the controller and calibrate all sticks including the X1 (lever for old and tilt dial for new). Make sure it applies. Close RC12.
    Start Phantom assist > Basic > RC. Calibrate the same. Make sure it applies.
    Make sure both sticks all move to the 1000 values in the Phantom assist.

    Also check your geo fence (max height and max distance). Change them to 999999999. Could be a chance that the geo fence is on and not letting you throttle up.