Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Vision Plus Start Up ISSUE

Discussion in 'Phantom 2 Vision + Discussion' started by jonas111, Nov 27, 2014.

  1. jonas111

    Joined:
    Nov 27, 2014
    Messages:
    11
    Likes Received:
    0
    Well I researched for a while and decided to get the newest Phantom 2 Vision Plus and it arrived today. I wish I had good news. I turned on the unit on and it powered up fine but the battery was low. I turned it all off and charged the battery.

    Once fully charged I put the battery back into the Phantom and tried to turn it on. It seemed to turn on for a second then turn itself off. This happened numerous times. After reading the manual over and over and I couldn't find anything that would explain the battery not powering up. So I called the place I ordered it from and he walked me through turning it on again. So I turned it on and held it for the two seconds and after the third attempt smoke started to billow our of one of the arms. I am fairly upset at this point and he asked me to send it back to him.

    Has anyone had this happen to them at all??? Or did I just get a dud???

    Not a happy camper right now.
     
  2. Larry L

    Joined:
    Oct 17, 2014
    Messages:
    671
    Likes Received:
    39
    Location:
    Copperas Cove, Texas
    seems like you got a dud. I have not had any problems with mine in that aspect. Good luck with the replacement.
     
  3. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    17
    You definitely got a dud or.... The prop guards came with longer screws. If the prop guards where removed and then the long screws went back in place they short the motor windings and cause what you just experienced. It burns up an esc and smoke pours out.
     
  4. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Ignore..
     
  5. jonas111

    Joined:
    Nov 27, 2014
    Messages:
    11
    Likes Received:
    0
    Not sure what this is supposed to mean. Hmmm

    But to reply to the other post above, i didn't even get the motors turning. I literally was trying to turn it on. While turning it on it started smoking.

    I'm assuming a dud but doesn't make me feel very confident these are well built.

    I have seen enough YouTube clip crashes to think they must be durable.
     
  6. CyberCitizen

    Joined:
    Nov 23, 2014
    Messages:
    85
    Likes Received:
    4
    Location:
    Adelaide, South Australia
    Ask Him To Swap It With The v3, And Pay The Slight Difference.
     
  7. jonas111

    Joined:
    Nov 27, 2014
    Messages:
    11
    Likes Received:
    0
    It is the V3.
     
  8. GSSP

    Joined:
    Nov 25, 2014
    Messages:
    302
    Likes Received:
    21
    The left stick is down in throttle lock causing the motors to shut down after start up
     
  9. jonas111

    Joined:
    Nov 27, 2014
    Messages:
    11
    Likes Received:
    0
    I am sorry but I am not sure what you mean by this. Are you saying that out of the box it was in throttle lock and that might prevent it from turning on?

    Please elaborate a little more if you have some insight as to what may have been the cause.
     
  10. dbooty

    Joined:
    Sep 6, 2014
    Messages:
    67
    Likes Received:
    4
    Location:
    Melbourne, Australia
    I would suggest something more serious than throttle lock would have caused smoke to come out.

    Return it and get another Jonas :)
     
  11. Damon

    Joined:
    Jun 25, 2014
    Messages:
    674
    Likes Received:
    5
    Location:
    Eastern Wa.
    After start up CSC you will need to move throttle out of lock position within 2-3 seconds. (To nuetral middle) Otherwise it will turn back off.

    But OP has a bigger problem. Smoke=Bad