Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Vision+ No Live Video

Discussion in 'Phantom 2 Vision + Help' started by matthewh, Dec 12, 2015.

  1. matthewh

    Joined:
    Mar 8, 2014
    Messages:
    23
    Likes Received:
    0
    I have not used my phantom in about a year. Last time I tried, about year ago, I could get no live video on my phone. At that time an iphone 5s. I figured it was an app issue and it has sat in its case ever since. Today I updated firmware on both phantom and controller.

    Main Controller 3.14
    GPS 6.0.1.4
    Receiver-5.8G 1.0.1.3
    P330CB 1.0.2.10
    Battery 2.0.0.0
    Zen IMU 1.0.0.6 (hardware id -1)

    RC System
    firmware 1.0.2.31
    loader 12.1.0.3

    So I try again. This time with my iphone 6s. App version 1.0.54(1946). Same thing. No video. I can see telemetry data. I can rotate camera up and down with app. I can snap photos and videos with the app and then see them with the album viewer in the app. I just cannot get a live view. I have deleted the app from iphone and then reinstalled. I have preview turned to lowest setting.

    Any ideas?
     
  2. ___1___

    Joined:
    Aug 5, 2015
    Messages:
    103
    Likes Received:
    51
    sounds like bad wifi trans module.
     
  3. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    ^^^^
    what he said.
    wifi unit burned hence no video output
     
  4. Teri

    Joined:
    Nov 2, 2015
    Messages:
    6
    Likes Received:
    2
     
  5. Teri

    Joined:
    Nov 2, 2015
    Messages:
    6
    Likes Received:
    2
    Like they all said, the WIFI trans. module is burned out. A New one costs $179.00- $189.00. I would avoid buying one from Ebay because it may be old. The new replacement has vent holes all over the top cover. It's an easy fix. Search Youtube, you will find a video that was made on replacing the module.
    I bought my P2V+ in Sept. 2014, and did not get around to powering it up till Nov. 2015 . Went crazy thinking software / firmware was the issue. Only after exhausting all the software combinations did I entertain the possibility the drone was dead on arrival. I opened up the Phantom and noticed a moldy
    smell coming from the trans. module. It was quite intense. I searched this forum and found out that back in 2014 many people were having the "no live video feed problem", and the module was the culprit. That was enough evidence for me. I Replaced it and it works fine. Now my GPS signal is being interfered with. I will try covering the GPS cable with metal tape. I also have a motor that does not spin as freely as the other 3. The problems go on and on...... Teri