Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 RC Help

Discussion in 'Phantom 2 Help' started by BZMac, Jun 5, 2015.

  1. BZMac

    Joined:
    Jun 5, 2015
    Messages:
    27
    Likes Received:
    0
    Location:
    Martha's Vineyard
    Greetings All -
    First time drone owner, bought a Phantom 2 V2 base model and flew it successfully for several weeks with no troubles/crashes. I decided to install the 2.4G datalink, and had a crash into the tree line from about 75-100 feet. After going through the P2 and taking care of error 26, recalibrwting, etc... I took it to fly on my stock remote. On my flight attempt, I realized that I needed a gain adjustment in order to lift (due to a heavier aftermarket battery).

    When I made the adjustment in phantom assistant, and attempted to check the RC, my calibration of U and X2 are way high unless in the center position, and it gives me the troubleshooting suggestion. So my question is why will the remote not calibrate properly? Could it have something to do with the datalink information I had loaded prior to the crash?
     
  2. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,244
    Likes Received:
    1,614
    Location:
    Palm Beach Co.- FL
    A bit confused...

    Is the "2.4G datalink" a control radio system or video Tx equip?
    The P2's OEM control system is on 2.4G also so you can't typically have both systems on the same band.

    The P2 uses a proprietary battery, which one is heavier?

    "Gain" settings do not affect lift, thrust, speed, etc.

    You must calibrate the control Tx first using the DJI RC System Assistant, then calibrate the Tx to the quad by using the DJI Phantom 2 Vision Assistant.
     
  3. BZMac

    Joined:
    Jun 5, 2015
    Messages:
    27
    Likes Received:
    0
    Location:
    Martha's Vineyard
  4. BZMac

    Joined:
    Jun 5, 2015
    Messages:
    27
    Likes Received:
    0
    Location:
    Martha's Vineyard
    This may be as a result of selecting Mode 2 in TX calibration.