Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard P3STD - RC Signal lost in few min

Discussion in 'Phantom 3 Help' started by SaintMarkus, Jun 14, 2016.

  1. SaintMarkus

    Joined:
    Jun 14, 2016
    Messages:
    2
    Likes Received:
    0
    Jello!

    Can you help me out?

    I updated P3 standard to newest firmware and updated rc. Now it doesn't make any sense, rc finds p3s and it connect but rc disconnects after few minutes.

    Any ideas?
     
  2. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    3,983
    Likes Received:
    1,162
    Location:
    Brookeville, MD, USA
    We need more specific details. What is your flying environment? What disconnects?
     
  3. SaintMarkus

    Joined:
    Jun 14, 2016
    Messages:
    2
    Likes Received:
    0
    Normal park without any big antenas or masts.

    I was able to do calibration and fly like 20seconds then RC and P3S connection was lost.
     
  4. Dilan Darshana

    Joined:
    May 21, 2016
    Messages:
    64
    Likes Received:
    8
    Hey bro you are not the only one having this issue.. i m loosing radio signal at 40m - 60m.. some people video signal like you.. it comes with the new 1.6.80 update, and thee are lot of people out there having the same issue.. if you ask DJI they will say to send the drone back to repair, that is the only thing they say and still there is no clear solution for this.. but we can wait for another fixed firmware upgrade, yesterday came a new firmware for phantom 3 pro, so I hope standard will also get new one very soon, and if it is not going to fix the problem, we all have send i back, including you and me..