Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3P SDK New Firmware released V01.01.1007

Discussion in 'Pro/Adv Discussion' started by Sky King, Jul 21, 2015.

  1. Sky King

    Joined:
    Jul 19, 2015
    Messages:
    159
    Likes Received:
    66
    This is for those in the SDK program. This apparently restores Ground Station. Anyone in the program going for it? Anyone in the program done it and had success with it? This is especially important for those Beta testing FreeSkies Co-Pilot.
     
  2. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    you need the beta SDK plus an app that supports the GS and POI function. Currently, there are two. Litchi and Ultimate Flight. Both are in alpha/early beta status but I've been testing Litchi and the GS and POI both works great.

    Litchi does have the added bonus of having a cool "VR" FPV mode where you can stick your phone in a google cardboard or samsung gearVR type device and fly FPV with huge FOV.

    Looking forward to trying out FreeSkie's Co-Pilot as it seems to be more focused in Videography, my area of interest.
     
  3. Sky King

    Joined:
    Jul 19, 2015
    Messages:
    159
    Likes Received:
    66
    So, this does NOT restore the DJI Ground Station operability, but only gives the capability to the apps which have been developed? Did you lose anything that the last update brought forward?
     
  4. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    i think this new beta SDK firmware is exactly the same as existing 1.26/1.28 firmware + support for SDK functionality. so you don't lose or gain anything. if you had issues with 1.26, you'd still have issues.

    There is no native DJI Ground Station functionality currently. Need to rely on third party apps.
     
  5. Sky King

    Joined:
    Jul 19, 2015
    Messages:
    159
    Likes Received:
    66
    Got it! Thanks. Gives me confidence in installing it in advance of Co-Pilot beta.
     
  6. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    one thing to be aware of though- if you are currently on 1.19 and don't want to upgrade to 1.26 because of potential VPS and other known firmware issues, you might want to hold off on the SDK firmware.

    It looks like the current SDK firmware is 1.26+SDK functionality and there is no way to roll back to older firmware after you install this.
     
  7. mikesher

    Joined:
    Mar 16, 2013
    Messages:
    158
    Likes Received:
    30
    Location:
    Seattle
    Can I install this on top of 1.26?
     
  8. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    yes
     
  9. Sky King

    Joined:
    Jul 19, 2015
    Messages:
    159
    Likes Received:
    66
    I installed it and flew 2 missions today w/o any problems
     
  10. KykPhantom

    Joined:
    Jun 28, 2015
    Messages:
    85
    Likes Received:
    17
    The controller currently being on 1.2.6, does not update. Is this normal or any idea?
     
  11. KykPhantom

    Joined:
    Jun 28, 2015
    Messages:
    85
    Likes Received:
    17
    Have you updated the controller successfully with SDK firmware?
     
  12. Sky King

    Joined:
    Jul 19, 2015
    Messages:
    159
    Likes Received:
    66
    The controller does not update with new firmware. As long as you have the latest 1.2.6, as has been mentioned above, you're good!