Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Standard rc signal lost, last firmware issue

Discussion in 'Standard/4k Discussion' started by szalaiberci, Jan 2, 2016.

  1. szalaiberci

    Joined:
    Jan 1, 2016
    Messages:
    16
    Likes Received:
    0
    Hi!
    I read a lot of topic about this but nothing helped me.
    So i upgrade the firmware with no problems. In the end of the upgrading the app said restart my aircraft and controller. After that yellow led flashing in the drone and in the app shows "rc signal lost". I try to re link a lot of times, i format the sd card but nothing. I try to reupgrade the firmware but it always stop at 20% and 49% than it say upgrading fail.
    I am sad because i got the drone few days ago and a factory upgrade destroy it.
     
  2. szalaiberci

    Joined:
    Jan 1, 2016
    Messages:
    16
    Likes Received:
    0
    I solved the problem... It takes 1 day but i solved!
     
  3. dxdx65

    Joined:
    Jan 1, 2016
    Messages:
    11
    Likes Received:
    2
    Hello, which was the issue then??
     
  4. szalaiberci

    Joined:
    Jan 1, 2016
    Messages:
    16
    Likes Received:
    0
    I dont know... I think there was a big trouble inside the software. in my opinion the idea from the development that upgrade the drone via smartphone isnt a good thing.
    First i deleted the phantom wifi from my iphone.
    I reseted my controller wifi ()
    I turned on the aircraft and i reconnect my phone to the phantom wifi
    Then i started to upgrade again.
    Fortunatelly everything was ok. While i doing that i heard a lot of noise from the aircraft and from the controller but in the end everything worked.
     
  5. John Rees

    Joined:
    Jan 1, 2016
    Messages:
    11
    Likes Received:
    0
    I had a pretty bad crash yesterday the 8 grey wires that plug the camera in were ripped out as well as the dark grey wire. I'm pretty sure i connected them properly. But now the p3 link light is green and the controller light is red. The app in the camera view says it is disconnected. Any ideas?
     
    #5 John Rees, Jan 2, 2016
    Last edited: Jan 2, 2016
  6. szalaiberci

    Joined:
    Jan 1, 2016
    Messages:
    16
    Likes Received:
    0
    Have you tried to relink ?
     
  7. John Rees

    Joined:
    Jan 1, 2016
    Messages:
    11
    Likes Received:
    0
    Yeah I did and the controller just keeps beeping and the red power light stays on never turns green


    Sent from my iPhone using PhantomPilots mobile app
     
  8. szalaiberci

    Joined:
    Jan 1, 2016
    Messages:
    16
    Likes Received:
    0
    But did you press the small button on the drone?
     
  9. John Rees

    Joined:
    Jan 1, 2016
    Messages:
    11
    Likes Received:
    0
    I did. Funny thing is when I turn both the controller and drone on the drone light turns green like it's linked but the controller does not


    Sent from my iPhone using PhantomPilots mobile app
     
  10. Zone 5

    Joined:
    Dec 24, 2015
    Messages:
    52
    Likes Received:
    10
    If that ribbon cable is not correct and connected, the drone will not link correctly. Even if the camera is broken no ribbon cable, no fly.
     
  11. John Rees

    Joined:
    Jan 1, 2016
    Messages:
    11
    Likes Received:
    0
    Thanks for the help. I'm taking it to a shop to have them look at it


    Sent from my iPhone using PhantomPilots mobile app