Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Bought today, return tomorow

Discussion in 'Pro/Adv Discussion' started by Richard P Kain, May 22, 2015.

  1. Richard P Kain

    Joined:
    Mar 31, 2015
    Messages:
    10
    Likes Received:
    0
    With much anticipation I bought my 1st Phantom 3 Advanced today, Followed all instructions and A. The motors do not turn on, On the Pilot Ap I get a DISCONECTED notice at the top of the display And a black screen (the sat map does show up in the corner though). Did the firmware upgrade on both the Phantom and the Remote. But alas no improvement. I Own 2 Phantom 2vplus so I know how to turn start the motors.
     
  2. Julius717

    Joined:
    Sep 24, 2014
    Messages:
    548
    Likes Received:
    248
    what app android or IOS? if adroid you need to enable developer mode.

    why give up so easy this isn't a p2+ big difference between the two
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,409
    Likes Received:
    567
    Location:
    Sydney Australia
    What device you using? Not all devices are compatible.
     
  4. loganintx

    Joined:
    May 10, 2015
    Messages:
    61
    Likes Received:
    9
    Are you returning it so you can buy the P3P?
     
  5. Charmande

    Joined:
    Apr 26, 2015
    Messages:
    75
    Likes Received:
    15
    Sounds like you don't have the cable from your remote plugged into your cell phone/tablet. Either way if you don't want it I'll gladly take it.
     
  6. Richard P Kain

    Joined:
    Mar 31, 2015
    Messages:
    10
    Likes Received:
    0
     
  7. Richard P Kain

    Joined:
    Mar 31, 2015
    Messages:
    10
    Likes Received:
    0
    Adroid Pilot ap, even tried deleting ap and downloading again, I would know how to enable developer mode. Pilot ap read that firmware upgrade was needed if I got a No Conection bar at the top. So I did the up grade. same problem and the motors will not start. I really wanted this, I have two Phantom 2vPlus and I knew this was more involved, however I and my son the tech geek spent 6 hours trying to find the cure. I mean I know to start the darn motors that pretty basic.
     
  8. NickCopter

    Joined:
    Jan 2, 2015
    Messages:
    471
    Likes Received:
    141
    Location:
    Grand Rapids, Michigan
    If you're getting "No connection" at the top try these steps, they worked for me

    Courtesy of fellow forum member Coldfire
     
  9. Richard P Kain

    Joined:
    Mar 31, 2015
    Messages:
    10
    Likes Received:
    0
    The cable was in fact plugged in and the pilot ap launched on my tablet as soon as I powered the remote.
     
  10. Julius717

    Joined:
    Sep 24, 2014
    Messages:
    548
    Likes Received:
    248
    Im confused. You Said you would know how to enable developer mode or not ?


    Sounds to me that's your issue.
     
  11. NickCopter

    Joined:
    Jan 2, 2015
    Messages:
    471
    Likes Received:
    141
    Location:
    Grand Rapids, Michigan
    Read my post and try it.

    Can you control the gimbal with your controller? Also generally while phantoms are in update mode/plugged in (including the P2) they can't have the motors powered on, as a safety precaution.
     
  12. Richard P Kain

    Joined:
    Mar 31, 2015
    Messages:
    10
    Likes Received:
    0
    Yes I can control the gimbal, and no I did not try to power the motors while update. I went through the set up set by step following the video tutorials and the manual. And did the update to the letter.
     
  13. Richard P Kain

    Joined:
    Mar 31, 2015
    Messages:
    10
    Likes Received:
    0
    No I do not know how to get to the the developer mode, or even what to do once I found it.
     
  14. NickCopter

    Joined:
    Jan 2, 2015
    Messages:
    471
    Likes Received:
    141
    Location:
    Grand Rapids, Michigan
    If you tell us what android device you're using we can point you towards a tutorial to help you. It might be that you don't have USB debugging enabled.

    It also might be that you are turning the pilot app on too early. Evidently you need to have the controller and the phantom on before turning on the Pilot app.
     
  15. Julius717

    Joined:
    Sep 24, 2014
    Messages:
    548
    Likes Received:
    248
    Simply Google devoloper mode for android and enable USB debugging. That's your problem.
     
  16. louforgiveno

    Joined:
    Jan 16, 2015
    Messages:
    644
    Likes Received:
    251
    Go to settings / about device then click on build number repeatedly till you see a message that saws developer mode enabled....then go back to main setting page and select developer options and place a check mark in the usb debugging tab Screenshot_2015-05-21-22-42-45.png Screenshot_2015-05-21-22-42-52.png Screenshot_2015-05-21-22-42-59.png
     
    Julius717 likes this.
  17. tails_naf

    Joined:
    Apr 11, 2015
    Messages:
    3
    Likes Received:
    0
    Did you download the app from the dji website or the play store? I used the one on the play store and it did not work well at all. You have to get the latest app directly from the dji phantom downloads area.
     
  18. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,506
    Likes Received:
    1,385
    Location:
    Salt Lake City, UT
    They are both the same now.
     
  19. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,744
    Likes Received:
    1,092
    Location:
    Long Island, NY
    Once you've figured out how to enable USB debugging, the next thing to try is to rebind your controller w/ the bird.
     
  20. djfxprogressive

    Joined:
    Sep 16, 2014
    Messages:
    24
    Likes Received:
    4
    I agree with USB debugging. Also, I believe that you need to register your Phantom through the app before you can start your motors.
     
    damitjim likes this.