Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P1 not holding GPS position

Discussion in 'Phantom 1 Help' started by gringorio, May 20, 2015.

  1. gringorio

    Joined:
    Sep 26, 2014
    Messages:
    241
    Likes Received:
    70
    Location:
    Tucson, AZ
    So last fall I posted about my P1 crash when the motors simply stopped when it was at a hover about 40-50' above the ground. Never figured out why that happened.

    But I've recently had time to try and get the P1 flying again and it's very squirrely with any inputs and will not hold position in GPS mode when I let go the sticks. When in GPS mode instead of hovering it 'slides' off to the side and loses altitude.

    I've calibrated the TX, the compass, updated the software and did an advanced IMU calibration. Props are balanced. I also pulled the lid to check for any loose connections and found nothing.

    So what I am wondering is could the compass be physically damaged (shows no external signs)? Could the IMU be damaged (no physical signs)? The crash was in tall thick grass, but it fell hard enough to bend the gimbal because the gimbal hit a hard lump of grass that the landing gear straddled. No other physical damage than the bent gimbal and broken 2 prop guards.

    Any thoughts or suggestions are much appreciated!

    ~gringorio
     
  2. gringorio

    Joined:
    Sep 26, 2014
    Messages:
    241
    Likes Received:
    70
    Location:
    Tucson, AZ
    Just saw this thread: http://www.phantompilots.com/threads/phantom-v1-1-wont-hover-in-place.39212/ I'll give this a try. However, the lights flash indicating GPS lock and there was no error code when hooked to to the assistant software...
     
  3. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    Sounds like you're flying my FC40... :(

    I don't think they like to be ignored. I didn't fly mine for months this winter. I've also looked for indications in the NAZA assistant, done the advanced IMU calibration, and the compass dance. I've even done this:
    http://www.phantompilots.com/threads/phantom-v1-1-wont-hover-in-place.39212/#post-382768


    I can haul *** all over the place, flies really well, just don't ask it to hold still. Mine wanders up and down, left and right, fore and aft. I'm suspecting the road base, gravel, that I have been flying from lately, but there may be bigger problems.

    When I apply full yaw, from as stable of a hover as it gets, it just wanders away. Yawing left, I think, it maintains altitude but travels quite some distance before it stops due to not moving the stick for 20 seconds. Yawing right, again - I think, it becomes very erratic and looses altitude as it wanders off.


    This is a great way to find things. Google Custom Search for our forum.
    Enter your text in the middle of the screen, not at the top.
    https://cse.google.com/cse/publicurl?cx=014775389315664725445:ejku2ysgyhi