Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Lost Image Transmition Signal

Discussion in 'Pro/Adv Discussion' started by Noah Sherman, Aug 13, 2016.

  1. Noah Sherman

    Joined:
    Apr 24, 2016
    Messages:
    3
    Likes Received:
    0
    Hey guys, so I have a Phantom 3 Pro and lately when I've been flying the drone loses Image Transmition Signal at only 600 feet away.
    Today I took off in my front lawn, flew to about 300 feet altitude and flew forward...
    At only around 5 or 6 hundred feet in distance I lost image transmition signal.
    This also happened in open fields, I've never crashed and I don't know what's up.
    Anyone else experience this or know what to do to fix this issue?
    Thanks guys!
    -- Noah
     
  2. Ridgekid

    Joined:
    Jul 2, 2016
    Messages:
    19
    Likes Received:
    0
    Try recalibrating before each flight? I had similar symptoms and this helped..
    Good luck! Dave


    Sent from my iPhone using PhantomPilots mobile app
     
  3. Noah Sherman

    Joined:
    Apr 24, 2016
    Messages:
    3
    Likes Received:
    0
    Thanks for the reply but I've been recalibrating before each flight
    Thanks again


    Sent from my iPhone using PhantomPilots
     
  4. FantomFlier

    Joined:
    Mar 21, 2016
    Messages:
    230
    Likes Received:
    76
    Recalibrate what?
     
  5. mikesmiley

    Joined:
    Apr 3, 2016
    Messages:
    452
    Likes Received:
    263
    Location:
    Sacramento, CA
    I was going to ask the same thing.
     
  6. neven

    Joined:
    Jan 5, 2016
    Messages:
    338
    Likes Received:
    114
    Location:
    Zagreb, Croatia, Europe
    Props

    Sent from my SHIELD Tablet K1 using PhantomPilots mobile app
     
  7. Noah Sherman

    Joined:
    Apr 24, 2016
    Messages:
    3
    Likes Received:
    0
    Recalibrating Compass and IMU


    Sent from my iPhone using PhantomPilots