Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. RUNUM

    Joined:
    Aug 16, 2016
    Messages:
    2
    Likes Received:
    0
    On my second time using the Litchi ap I lost connection at about 2000ft. The bird did not return to home automatically or after pushing the RTH button on the remote. Luckily I was able to hop into my truck and track it down until I got signal and bring it back. Anyone else have this problem? The ap was set to RTH if disconnected. Now I am afraid to use Litchi....
     
  2. CThruU

    Joined:
    Jun 21, 2016
    Messages:
    103
    Likes Received:
    38
    Location:
    West Virginia
    Were you flying a waypoint mission? If you lost RC connection, the RTH button will not initiate as it cannot communicate.

    Some info on that topic here:

    Litchi Waypoint Mission -- a couple of scary experiences that have made me much more weary!
     
  3. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    7
    Location:
    Glen Burnie, MD - USA
    If you are flying a waypoint mission it isn't supposed to RTH when you lose contact. It completes the programmed mission. If you are out of RC range you can't send an RTH command to the bird.

     
  4. RUNUM

    Joined:
    Aug 16, 2016
    Messages:
    2
    Likes Received:
    0
    I was not flying a mission. Just free flying. Any tips on what to do if this happens again?
     
  5. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    7
    Location:
    Glen Burnie, MD - USA
    Interesting I've never manually flown with Litchi. I use it exclusively for waypoint missions & use Go for manual flight. Message the author on the Litchi FakeBook page. He's very responsive.

     
  6. Helihover

    Joined:
    Jun 23, 2016
    Messages:
    234
    Likes Received:
    183
    Location:
    Oregon
    I've gone beyond range before on litchi and had no issue. Make sure your RTH settings are set to come home if the signal is lost. Default is hover, so if you never changed that in the GO app, there's your problem.
     
  7. RémyHeli

    Joined:
    May 23, 2016
    Messages:
    403
    Likes Received:
    60
    Beware settings might be reset to Default when upgrading firmware/software. Good practice is to review them after update.


    Sent from my iPhone using PhantomPilots mobile app
     
    Pharm likes this.
  8. SoundByte

    Joined:
    Jun 1, 2016
    Messages:
    77
    Likes Received:
    32
    The OP already indicated what his settings were. There has to be another explanation.
     
  9. fastfed

    Joined:
    Jul 5, 2016
    Messages:
    544
    Likes Received:
    161
    there are options for RTH with Litchi, I only use Litchi, never use the goapp ever since seeing how powerful Litchi is. Since you drove in your truck to get it, I assume it was just sitting hovering, a feature for Litchi under RTH options. I think Land,RTH and hover are the options.
    if it was showing RTH , it obviously wasn't set, reset it and make sure its applied.