Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Issues with warmup and compass calibration

Discussion in 'Phantom 1 Help' started by Didj, Dec 22, 2013.

  1. Didj

    Joined:
    Dec 15, 2013
    Messages:
    2
    Likes Received:
    0
    Ive been using my phantom for about two weeks now. However, I only fly it in atti or manual mode since I cant ever get the compass calibration and GPS to work. As soon as I plug in the battery, it does the initial checks which are good but it never does the warmup sequence (blinking yellow light). It goes straight to green, then 3 red blinks which is indicative of poor satellite reception this goes on for a while and never improves. So now I start the compass calibration by the book, flick the mode switch 10 times to get the yellow light then horizontal 360 then green light vertical 360 LED side up. All i ever get is a continuous blinking red (a failure in calibration/battery low). But my batteries are fresh. Upgraded to the 4.02 update with same results. Any insight on what the problem could be? Anyway, thats my story. I still love flyin my phantom though. But it would be nice to fly with the GPS mode features.
     
  2. DrMucker

    Joined:
    Oct 27, 2013
    Messages:
    10
    Likes Received:
    0
    it is possible it is just not right but before you do all that .. try this .. not going to say it will help but it might ..
    find a perfectly level platform hook it all up the way you would .. only this time leave the battery hanging outside the airframe .. dont try to it in the battery bay until the warm is is complete ... hook it up to the assistant and try doing the advanced IMU set up .. this will take about 5 to 8 minutes .. once the advanced calibration is done .. try doing a compass re calibration.. I found that this helped after a major crash .. since that time with no crashes it all seems to be working fine .. good luck hope this helps
     
  3. phantomflyer

    Joined:
    Nov 18, 2013
    Messages:
    244
    Likes Received:
    0
    Location:
    New Hampshire
    I believe you only get the warm up LED the first time you turn on your unit or in very cold weather when it will take sometime to warm up the components! Not sure on this just guessing because mine only gives me a system start and self check LED and goes right into to GPS search LED but I get all green lights, Sometimes I get them right away and there have been times I had to wait for almost two minutegs, But in your case you may not be getting them because you can't calibrate the compass. Have you check to see what you current compass levels are at on your assistant software? You may have to manually reset it with a magnet!!
     
  4. Didj

    Joined:
    Dec 15, 2013
    Messages:
    2
    Likes Received:
    0
    Thanks for the replies. Seems like i fixed the compass cal issue after degaussing the compass with a magnet while i have the phantom hooked up to the assistant so i could see the MOD numbers realtime. Finally got it within acceptable limits and it no longer gives me the blinking red light after the calibration dance. However the warmup process is still nonexistent even with the battery in/out the bay. As soon as I powerup, gives me the ready checks ok then straight to gps satellite status. No IMU warmup at all. It doesnt seem to affect the flight though. Also, its winter where im located
     
  5. phantomflyer

    Joined:
    Nov 18, 2013
    Messages:
    244
    Likes Received:
    0
    Location:
    New Hampshire
    Like I said ^ I wouldn't worry about the warm up, I don't get it and never had a problem. If it goes right to GPS then it's already warmed up a ready to go, I believe it's a light for if the Phantom cold and needs to warm up or be warmed up!!