Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

iOSD mini and FPV hub = black screen

Discussion in 'FPV (First Person View)' started by Dlandrum, Jun 27, 2014.

  1. Dlandrum

    Joined:
    Jun 1, 2014
    Messages:
    11
    Likes Received:
    0
    I have the Phantom 2, H3-3D gimbal, Hero 3+ working well.

    I have FPV working using the FPV HUB:
    Hero -> H3-3D -> H3-3D Anti-interference Reinforcement Board -> FPV Hub -> Flysight TX5804 400mw 5.8ghz -> FlySight 5.8ghz Circular Polarized Antenna (RP-SMA)

    2x FlySight 5.8ghz Circular Polarized Antenna (RP-SMA) -> FlySight RC801 Black Pearl Matte 7" w/ dual diversity receiver


    I have done a dry wire of the iOSD mini in my house. It has the right firmware. It blinks green.

    When I flip the switch on the FPV hub from VID to OSD, the screen goes from an image to full-black.
    I can disrupt the RX with a towel to get fuzzy-black, so I know full-black is being transmitted and not some function of the monitor.

    Any ideas?


    When on VID, I see info from the gopro: PROTUNE, 1080x24, battery-full/plugged-in.
    It seems the iOSD is just an overlay for what the gopro sends, but any idea how to turn off the gopro info?
     
  2. BMEWS

    Joined:
    Mar 25, 2014
    Messages:
    368
    Likes Received:
    0
    Location:
    Cambridgeshire UK
    it's in the gopro settings. OSD. have a look. I'm sure you'll find it ;)

    bmews
     
  3. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    As BMEWS mentioned you'll have to go in to the camera's settings to turn off that display info.

    As for the rest of the issue, do you have the FPV hub wired to the mainboard in the Phantom? There should be an 8-pin cable going from the hub to the port on the mainboard where the gimbal would connect if it wasn't plugged into the hub. Also, is the iOSD mini's canbus cable pugged in?
     
  4. Dlandrum

    Joined:
    Jun 1, 2014
    Messages:
    11
    Likes Received:
    0
    duh .. gopro osd turned off.


    The FPV hub is connected to the mainboard.
    The osd mini is connected to the fpv hub.
    The osd mini is connected to the can bus (no green lights without that).

    I reapplied the latest firmware to everything.

    ... still black screen.

    bummer, as everything else *phantom* has gone so smoothly.
     
  5. Cr8tive_leo

    Joined:
    Feb 6, 2014
    Messages:
    255
    Likes Received:
    1
    Location:
    Ontario, Canada

    did you try...

    Hero -> H3-3D -> FPV Hub -> Flysight TX5804 400mw 5.8ghz -> FlySight 5.8ghz Circular Polarized Antenna (RP-SMA)

    then FPV hub to H3-3D Anti-interference Reinforcement Board (which still goes to the main board)
     
  6. Dlandrum

    Joined:
    Jun 1, 2014
    Messages:
    11
    Likes Received:
    0
    good idea.

    I tried having the Anti-interference Reinforcement Board between the FPV hub and the main board ... no luck.

    I tried totally removing the Anti-interference Reinforcement Board ... no luck.
     
  7. Dlandrum

    Joined:
    Jun 1, 2014
    Messages:
    11
    Likes Received:
    0