Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

gimbal motor seems loud

Discussion in 'General Discussion' started by JRUSH311, Sep 21, 2015.

  1. JRUSH311

    Joined:
    Aug 24, 2015
    Messages:
    40
    Likes Received:
    3
    I noticed within the first 2 flights while mid flight the yellow error popped up for a few seconds
    "gimbal motor overload"
    it did it a couple of times and went away

    Im on around 15-20 flights now
    and Ive been noticing the gimbal motor is very loud
    when the craft starts up it happens a few seconds after the gimbal does the twisty motion
    the gimbal does work fine but its a lot louder than it was

    should I go ahead and send it in or this normal?
    I also just now noticed the led on front of the camera mount turns red
    so maybe this is a warning sound and not the motors?
    I was able to upgrade the latest firmware but could not get the rc to update
    possibly related?

     
  2. Karam Singh

    Joined:
    Sep 7, 2015
    Messages:
    12
    Likes Received:
    0
    Hey just a thought, did you remove that small white foam piece from the gamble after you bought it?
     
  3. Karam Singh

    Joined:
    Sep 7, 2015
    Messages:
    12
    Likes Received:
    0
    Wait sorry I take that back. That noise is not normal
     
  4. JRUSH311

    Joined:
    Aug 24, 2015
    Messages:
    40
    Likes Received:
    3
    what does the red led indicator light on the camera mount indicate?
    argh I hate to have to send it in and be without it forever
     
  5. Jeff48920

    Joined:
    Jun 25, 2014
    Messages:
    1,017
    Likes Received:
    502
    Location:
    Pomona, IL
    Just a couple of wild guesses
    1. IMU calibration
    2. Gimbal calibration
     
  6. JRUSH311

    Joined:
    Aug 24, 2015
    Messages:
    40
    Likes Received:
    3
    imu calibration didnt help but once I did the gimbal calibration it stopped right away

    thanks!
     
  7. Karam Singh

    Joined:
    Sep 7, 2015
    Messages:
    12
    Likes Received:
    0
    That loud noise is like an audio alert. Red led means firmware issue. I think maybe if you re install he firmware and YouTube has a lot of videos on how to do it step by step, it will fix your issue.
     
  8. Karam Singh

    Joined:
    Sep 7, 2015
    Messages:
    12
    Likes Received:
    0
    Also i think you should do a factory reset for everything