Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Front lights not working

Discussion in 'General Discussion' started by appleboy, Apr 17, 2013.

  1. appleboy

    Joined:
    Mar 29, 2013
    Messages:
    23
    Likes Received:
    0
    Had a little crash the other day and for some reason the front(rear) light doesn't work anymore. I'm talking about the one that tells me if the battery is going dead, if im green, yellow or red.

    I plug it into the computer and like turns on there. It flys fine. Any suggestions?
     
  2. Droneman

    Joined:
    Mar 20, 2013
    Messages:
    18
    Likes Received:
    0
    maybe try to open it and check some loose connections?.. how hard u crash?? have u try advance calibration?? check some wires i guess its wires but not sure..

    hope ul fix it soon
     
  3. FangsCPO

    Joined:
    Apr 7, 2013
    Messages:
    793
    Likes Received:
    3
    Location:
    Chula Vista, CA
    You do realize that's the rear of the Phantom? The nose of the Phantom is where the battery compartment lid is located.
     
  4. Audaciter

    Joined:
    Mar 18, 2013
    Messages:
    724
    Likes Received:
    2
    Location:
    Sunnyvale, California, USA
    If you take the shell off the top, you will find that the cable connecting the led/usb board is very short. Mine is stretched tight,
    to the Naza controller. It may have jarred it loose when you crashed, or the led/usb board could be damaged.

    And yes, the led faces the rear, so you can see it while you fly.
     
  5. appleboy

    Joined:
    Mar 29, 2013
    Messages:
    23
    Likes Received:
    0
    Hmm Ive taken it apart 2 times now and everything seems to be connected fine. I even unplugged it from the Naza controller and put it back in.

    I'll try the advance calibration.