Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Fire, mother board pv2+

Discussion in 'Phantom 2 Vision + Help' started by 904jason, Jan 7, 2016.

  1. 904jason

    Joined:
    Oct 2, 2015
    Messages:
    19
    Likes Received:
    0
    Twice I've had this problem this time after a new board all pieces new from scratch. It seems to be, what you call a node or diode were the aux Cam bus port for the outside leg wore comes into the body. All was fine never a good lock on GPS mainly snooty 3to5 sats then after messing with it with a flytrex core one installed. The only thing I can think happens is the flytrex wire was cross after putting it through the body. I hooked up were the wires right they aren't twisted cuz there tightly insulated and flat. So all is fine and I noticed the top of she'll was turned were front was side ways. And it flew with GPS. 7 sats locked. And all. After turning the top I never got any gps or motors to turn. Then new board same fire. This time no GPS no motor turn either. Nothing no beep no led. Check batt and connection to board 12v from batt but nothing to the board on shows continuity CPR power wires going in even changed GPS that burned with 2nd board I got for to mention. Got a new GPS and a new mother board same fire . And no power to board only batt registers on volt meter. Hope pics upload look close. There was power coming from the burnt area on the first and 2nd board.
     
  2. 904jason

    Joined:
    Oct 2, 2015
    Messages:
    19
    Likes Received:
    0
  3. 904jason

    Joined:
    Oct 2, 2015
    Messages:
    19
    Likes Received:
    0
    I'll up load them later. Right next to gps blk plug just to the left in front of aux Cam bus port
     
  4. 904jason

    Joined:
    Oct 2, 2015
    Messages:
    19
    Likes Received:
    0
    904 Jason the pics
     

    Attached Files: