Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Fast flashing red lights on power up

Discussion in 'Phantom 1 Help' started by CaptainK, Jun 22, 2013.

  1. CaptainK

    Joined:
    Jun 22, 2013
    Messages:
    4
    Likes Received:
    0
    So. I landed my Phantom swapped batts and then the motors refused to start. Went into Naza all seemed fine but needed firmware upgrade so did that, reimported DJI default config, re-calibrated IMU, made sure Futaba T8J was communicating and re-powered. Green/ yellow then fast flashing solid reds would go on and stay flashing red. Re-calibrated the compass... horizontal went well, after doing vertical it goes back to fast flashing red so I don't think thats the problem.

    Anyone with any ideas would be most welcome. Cheers. Kelvin
     
  2. Gizmo3000

    Joined:
    Jan 25, 2013
    Messages:
    1,859
    Likes Received:
    2
    Location:
    Sherman Oaks, CA
    I've had a few times where i got flashing red lights, unplugged the battery and reconnected and it went back to normal.
    go figure
     
  3. FrankB

    Joined:
    Jun 6, 2013
    Messages:
    145
    Likes Received:
    6
    Just happened to me too- found that if I removed, and then re-inserted the battery, the problem went away. However, when I did the advanced calibration, the problem also went away.
     
  4. CaptainK

    Joined:
    Jun 22, 2013
    Messages:
    4
    Likes Received:
    0
    I wish it was the case for me. I have tried reinitializing and no joy. My problems started after a simple landing and then the motors just would not start up so I wonder if something major went screwy
     
  5. FrankB

    Joined:
    Jun 6, 2013
    Messages:
    145
    Likes Received:
    6
    You need to re-calibrate both the electronics (accelerometer, gyroscope, etc.) but also separately, the controller joy sticks.

    Anyway, I had the same problem and it disappeared when I did both calibrations.