Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Constant Yellow Light Flashing

Discussion in 'Phantom 1 Help' started by CameraGuy, Jun 8, 2013.

  1. CameraGuy

    Joined:
    Jun 3, 2013
    Messages:
    318
    Likes Received:
    1
    OK, I just got a new phantom. I had one, and the old one hit the lake, so I bought just a new phantom body and battery.

    1. It is upgraded to the new firmware.
    2. The battery has been charged
    3. The batteries in the radio have been changed to brand new ones.
    4. I did a calibration in the NAZA software
    5. WHen I turn it on, I get 2 green lights for an instant.
    6. There is no sound from anything.
    7. I have checked under the hood and everything looks connected.

    No matter how long I leave the phantom on. Inside or out side, all I get is a constant yellow flashing light. The dealer swears he flew it the day before I bought it and it was fine.

    None of the other LED's are turned on.

    When you go to the DJI web site it says "Check that the receiver and the main controller are connected correctly"

    Of course there is no diagram, or photo, or instructions on how to do this.

    Did I just go from no Phantom to a bad one?

    I'm about to give up

    D
     
  2. GoodnNuff

    Joined:
    Jun 4, 2013
    Messages:
    1,909
    Likes Received:
    831
    Location:
    Washington State
    Is the tx you're using from the previous Phantom? As I understand this, you lost the 1st phantom, and replaced it with just the new quadcopter and a battery, using the radio from the first Phantom?

    If that is the case, you'll need to bind the TX/radio to the new Phantom/receiver. There are instructions on how to do this in the advanced manual on DJI's website.
     
  3. CameraGuy

    Joined:
    Jun 3, 2013
    Messages:
    318
    Likes Received:
    1
    Yep,

    That did it.

    Then I took it out side, calibrated the compass Got solid green lights, and tried to take off.

    Tipped to the right and destroyed a set of props.

    I must be too stupid to do this.

    Obviously I put the wrong props on the wrong engines. Is that the latest mistake?

    Starting to get way to frustrated.

    D
     
  4. Sac D

    Joined:
    Mar 3, 2013
    Messages:
    419
    Likes Received:
    1
    Location:
    Northern California
    Take your time and get the props right. It's easy to mess up if you don't double-check everything. Also, if you haven't done so already, load up the Phantom Assistant, and check to see if it tells you that there is a firmware update available. The latest is 3.12, and it has a new startup routine which will prevent you from taking off prematurely, and also makes for better performance.
    Good luck... you have this down very soon. It's not rocket science.
     
  5. Darrell1

    Joined:
    Apr 22, 2013
    Messages:
    179
    Likes Received:
    7
    Got SOLID green? If you are in GPS mode, after warm up, you should get two green flashes, a pause, then two more. If both sticks are centered, you will just get a single flash instead.

    I'm not sure what a solid green is. I'd have to look that up as I've never seen it.
     
  6. jasond415

    Joined:
    Mar 28, 2014
    Messages:
    8
    Likes Received:
    0
    I just upgraded to a futaba t8j and now I have one yellow flash every 1-2 seconds what does that mean?