Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera Shakes violently

Discussion in 'Phantom 2 Vision + Discussion' started by DSipp, Jun 2, 2016.

Tags:
  1. DSipp

    Joined:
    May 18, 2015
    Messages:
    13
    Likes Received:
    1
    i have a v2+. I have installed a new ribbon cable and now the camera shakes at power on and never stabilizes. i have adjusted the rear shaft and tried the side shaft in both positions available. other ideas?
     
  2. DroneDestination

    Joined:
    Jan 15, 2016
    Messages:
    698
    Likes Received:
    126
    The forward pitch motor doesn't seem to be working properly. The gimbal is trying to fix it. Also, the gimbal isn't balanced without the rear plate (which is removed in the video). Try again with said plate installed.
     
  3. DSipp

    Joined:
    May 18, 2015
    Messages:
    13
    Likes Received:
    1
    thanks for the reply. The motor behaves the same with the rear cover on.
     
  4. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Look at the top yaw shaft first. Make sure the grub screw sits against the flat side. Also check that the yaw shaft isn't bent. If its bent, it would put pressure on the bearing case and not let it rest properly. Looking at your video, it looks like it sits to one side when there is no power and it slaps to the sides when there is power. This will cause it to be unbalanced on initialisation. Another thing you can do is swap the axis boards around. The roll axis board shares the same as the tilt axis (DJI used the same boards in the H3-3D for the tilt axis). If that all fails, look at each of the axis boards and pop open the potentiometers by using your finger nails. Inspect the Omega rings and make sure there are no cracks.