Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera Not sending anything back to App

Discussion in 'Standard/4k Discussion' started by BrianV, Oct 18, 2015.

  1. BrianV

    Oct 16, 2015
    Likes Received:
    I ran into an issue where my camera stopped sending anything back to my Samsung phone. After messing with it for a while found that by cleaning out the app cache the camera works again.

    My USB never did work and SD card is not wanting to come out of the camera and I am not going to force it out for fear that the spring or something may break. I have talked with he vendor and I may be sending it back to them in exchange for another unit, I am thinking about upgrading it to the P3A. I had this USB problem right out of the box, but I played with it for a couple weeks and it just wont work, I tried 4 different computers and they are say the device is defective and the USB device is not recognized. So finally I gave up on that. I have had the unit since Oct 6th.

    I tried several things the vendor had suggested and no luck...so there is certainly something wrong with it...:(.

    Hopefully I can work it out with them and get this resolved. The P3S works great other than that, I love it.

  2. dirkclod

    dirkclod Moderator
    Staff Member

    May 9, 2014
    Likes Received:
    Amory Mississippi
    Welcome to the forum Brian :)
    If you have done all that and tried another cable something is wrong .
    I've had a bugger of a time getting my sd card out and the other day I kinda pushed it down and a little to the left
    and it jumps out :rolleyes:
    Good luck .