Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera/Gimbal not working!!! Ahhhhhhh!!!

Discussion in 'Phantom 2 Help' started by MikeyG4753, May 29, 2014.

  1. MikeyG4753

    Joined:
    May 6, 2014
    Messages:
    7
    Likes Received:
    0
    Location:
    Philadelphia, PA
    Morning everyone! Is anyone familiar with the wires that go from the camera/gimbal to the inside? I'm not sure if there's a loose wire or a short somewhere... The camera and gimbal stopped working a few days ago. They don't turn on upon startup, the LED light doesn't show any color, there is also no response when I connect the USB to the computer...

    Please help!
     
  2. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    Whoaa back up, take a breath - then tell us what Phantom, what gimbal, what camera and maybe upload some pics - so we might help you.

    edit: now that I see you posted it in another section (P2 V+) - Did you crash it recently? From the syptoms you supplied I suspect you're going to have to open it up and inspect internal connections.
     
  3. MikeyG4753

    Joined:
    May 6, 2014
    Messages:
    7
    Likes Received:
    0
    Location:
    Philadelphia, PA
    Sorry, I'm not very familiar with posting to forums so I'm not really sure where this was going to show up... Yes, it's a P2V+... I did crash it and it went under the water for a little bit. I dried it out in some rice for a few days. I took it apart and blew all of the dist away with some canned air. It was flying good fine and the camera and gimbal worked for a few days... Then went to fly one night and got nothing from either. I'll take it apart again when I get home and will upload some pics of the internals.