Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

5.8GHz vRx suddenly affected by 2.4 GHz DJI controller

Discussion in 'FPV (First Person View)' started by tferrari, Sep 1, 2014.

  1. tferrari

    Joined:
    Aug 4, 2014
    Messages:
    145
    Likes Received:
    1
    Not sure what changed recently but I noticed my FPV signal quality was seriously degrading. It was getting progressively worse and now it's completely useless.

    Current setup
    ImmersionRC 600mw video transmitter wired directly into GoPro (bypassing gimbal); power source is from the Phantom.
    Boscam LCD-5802 diversity receiver
    Stock DJI radio controller

    Symptoms
    White banding when moving more than 10 feet from controller. Static is seriously reduced when the orientation of radio controller antenna is changed or when my hand is put between the video receiver and antenna. Seems like a 2.4 GHz interference thing to me.

    Things I've tried
    Changing antennas - I've used the generic ones that came with the unit, spironets and my FPVLR antennas. No difference
    Using Boscam 200mW vTx - no difference in signal
    Trying all different video channel combinations on transmitter and receiver
    Moving to a location with less chance of interference
    Checked all Phantom internal connections for video ensuring a good solder connection
    Moving the receiver 10 feet away from radio controller - symptoms somewhat improve but cannot get more than 30 feet of range

    Things I have not tried
    Changing video receiver
    Changing radio controllers

    --

    I really think there an issue with the receiver so I ordered the immersionRC duo receiver.

    Just wanted to see if anyone had any input.
     
  2. noiseboy72

    Joined:
    Jul 13, 2014
    Messages:
    575
    Likes Received:
    17
    Location:
    Lincs, UK
    I sometimes see the same - but on a less severe basis. With the TX on, I get white ghost flickers across the screen.

    Never bothered to cure it, as it does not affect me flying FPV, but I will check to see if it gets worse.
     
  3. tferrari

    Joined:
    Aug 4, 2014
    Messages:
    145
    Likes Received:
    1
    I'm surprised no one else has responded to my post :p -- I've seen a number of videos on YouTube that document this same issue but I can't find the cause.
     
  4. gordonthree

    Joined:
    Sep 3, 2014
    Messages:
    1
    Likes Received:
    0
    I notice this too... originally with my boscam rx832 and a cheapy lcd, and now a black pearl. Moving the antenna on the phantom remote usually helps. I've narrowed it down to the power output of the remote's tx. The 2.4 ghz power from the remote is affecting the circuits of the display itself. I have noticed the banding on my cheapy display even with the rx powered off.

    Make sure the tx antenna is 90 degrees perpendicular to your display. Something I haven't tried but might work is some foil or metal screen across the back of the display, to protect it from radiation from TX antenna that is very close now that the pearl is mounted directly to the remote.
     
  5. tferrari

    Joined:
    Aug 4, 2014
    Messages:
    145
    Likes Received:
    1
    It didn't do this 2 weeks ago. What would make it suddenly start other than some kind of component degradation? Weird...